Closed Bug 1223747 Opened 5 years ago Closed 5 years ago

Don't assume all frames are visible in XUL documents

Categories

(Core :: Layout: Images, Video, and HTML Frames, defect)

defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla48
Tracking Status
firefox48 --- fixed

People

(Reporter: seth, Assigned: seth)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

We shouldn't assume all frames are visible when the top-level content document is a XUL document. This is true for mochitests, which means that mochitests are not running in an environment that is comparable to a real web page.
Here's the patch.
Attachment #8685968 - Flags: review?(tnikkel)
Attachment #8685968 - Flags: review?(tnikkel) → review+
Background: I originally included XUL docs to make it easier to turn on image visible with less chance of regressions. There wasn't anything specifically blocking turning it on for xul docs, just little upside in enabling it there.
(In reply to Timothy Nikkel (:tn) from comment #2)
> Background: I originally included XUL docs to make it easier to turn on
> image visible with less chance of regressions. There wasn't anything
> specifically blocking turning it on for xul docs, just little upside in
> enabling it there.

Thanks for the review! Based on the try results, it looks like everything went ok.
This seems like something that would be good to get landed ASAP, as then any changes it causes can be easily tracked and noticed sooner.
https://hg.mozilla.org/mozilla-central/rev/5209d6b9fe6e
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla48
Product: Core → Core Graveyard
Product: Core Graveyard → Core
You need to log in before you can comment on or make changes to this bug.