If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

SOCKS proxy is bypassed silently when the proxy server dies

RESOLVED DUPLICATE of bug 1207798

Status

()

Core
Networking
RESOLVED DUPLICATE of bug 1207798
2 years ago
2 years ago

People

(Reporter: mike, Unassigned)

Tracking

44 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:44.0) Gecko/20100101 Firefox/44.0
Build ID: 20151111004055

Steps to reproduce:

Running 44.0a2 (2015-11-11) on Debian 8.

1. Configure a SOCKS proxy (e.g. ssh -D4567 you@yourserver)
2. Using Firefox manual proxy configuration, SOCKS host 'yourserver', Port 4567, SOCKSv5.
3. Confirm web-facing IP address is the address of 'yourserver.' (Google "what's my ip?" or similar test.)
4. Kill SSH connection/SOCKS proxy. Do not change Firefox proxy configuration.
5. Verify IP address again.


Actual results:

On step 5, the proxy fails open and you will be able to browse the internet on your local internet connection, unproxied.


Expected results:

The "proxy server is refusing requests" error page should be displayed, and no connectivity possible.
Thank you for the report, this issue has already been filed as bug 1207798.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Component: Untriaged → Networking
Product: Firefox → Core
Resolution: --- → DUPLICATE
Duplicate of bug: 1207798
You need to log in before you can comment on or make changes to this bug.