Last Comment Bug 122389 - espn.go.com - Major layout problems @ ESPN
: espn.go.com - Major layout problems @ ESPN
Status: RESOLVED FIXED
: top100
Product: Tech Evangelism Graveyard
Classification: Graveyard
Component: English US (show other bugs)
: unspecified
: x86 All
: -- normal
: Nov
Assigned To: english-us
:
Mentors:
http://sports.espn.go.com/nhl/clubhou...
: 132587 139931 168341 171249 (view as bug list)
Depends on:
Blocks: 119194
  Show dependency treegraph
 
Reported: 2002-01-29 08:57 PST by jsnod
Modified: 2015-04-19 23:39 PDT (History)
8 users (show)
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
Screencap of the problem (52.30 KB, image/jpeg)
2004-02-05 14:32 PST, jsnod
no flags Details
Screencap of Problem (Worse) (31.02 KB, image/jpeg)
2004-06-11 08:59 PDT, jsnod
no flags Details

Description jsnod 2002-01-29 08:57:16 PST
I need some evangelist help to fix up ESPN's pages.  The layout is disrupted to
the point of non-readability.  I've contacted them numerous times, and they've
replied with "we are fixing it" numerous times.  The homepage
(http://sports.espn.go.com/nhl/index) displays fine, but the indivisual team
pages are where problems arise.
Comment 1 Brant Gurganus 2002-02-26 14:35:50 PST
Confirmed
2002022203/WinXP
Comment 2 Boris Zbarsky [:bz] (Out June 25-July 6) 2002-04-24 22:29:53 PDT
*** Bug 139931 has been marked as a duplicate of this bug. ***
Comment 3 Stan Bubrouski 2002-05-05 15:13:34 PDT
This is not a browser issue, it is indeed a site issue, the javascript on the
page loads different style sheets
(http://espn.go.com/insertfiles/css/mlb/font_nn.css for netscape and
http://espn.go.com/insertfiles/css/mlb/font_ei.css for IE)... if you load the
page with the IE stylesheet it looks normal and there is less overlap, I used
mlb as an example (http://sports.espn.go.com/mlb/index) but it applies to most
espn.com pages.  Nothing can be done until they fix their site for
Mozilla/Netscape6+
Comment 4 Steve Schwartzberg 2002-05-13 12:46:30 PDT
Interestingly, I see this issue on my Win2k machine at work, for all versions >
0.9.8.  My home Win2k machine doesn't have this issue. 

Is there some setting to force a stylesheet, or perhaps a java version issue?
Comment 5 Arno Roefs 2002-06-09 11:23:11 PDT
See also http://bugzilla.mozilla.org/show_bug.cgi?id=146860
Comment 6 Mike Schiraldi 2002-07-12 11:42:45 PDT
I suggest that some or all of the following bugs are marked as dupes of this one:

146860 espn.com - solution (browser detection...)
149068 Bad text layout on espn
140567 espn.com - changing visibility doesn't work
136187 espn.com: Rendering issue
130076 Mail freezes when displaying message from ESPN
99161  go.com - Table Layout Shown Incorrectly at ESPN Message B...
152034 Layout of ESPN Soccer page is not good - lines are overla...
154023 Crash when voting on espn.go.com [@ nsPluginInstanceOwner...
Comment 7 Greg K. 2002-07-15 22:06:38 PDT
*** Bug 132587 has been marked as a duplicate of this bug. ***
Comment 8 Bob Clary [:bc:] 2002-08-15 10:04:08 PDT
doesn't appear to be in "The Americas" component. I am dealing with ESPN today,
so will reassign.
Comment 9 Bob Clary [:bc:] 2002-08-15 10:06:10 PDT
Mine! Mine! All Your Base Belongs to Me!
Comment 10 Bob Clary [:bc:] 2002-08-15 10:29:15 PDT
These issues are all related however I wish to point to the individual bugs when
I contact them. Please do not dupe.
Comment 11 Simon Fraser 2002-09-13 09:43:46 PDT
*** Bug 168341 has been marked as a duplicate of this bug. ***
Comment 12 Mats Palmgren (:mats) 2002-10-02 17:09:31 PDT
*** Bug 171249 has been marked as a duplicate of this bug. ***
Comment 13 j lee 2003-05-11 09:29:44 PDT
My problem isn't really on the MLB page, but the main page that opens when you
visit espn.com. My layout problems occur because of the new advertisement style
that espn is incorporating. The ad on the top frame is initially a large flash
image, and it gradually decreases after 5 seconds or so that the page is open.
When this decrease occurs, the site is impossible to navigate.
Comment 14 Mike Schiraldi 2003-05-11 10:10:16 PDT
Yes, i agree that the new espn.com homepage is a major major problem.

I do have a temporary workaround:

Install <a href="javascript:(function(){var d=document; function K(N,t) { var b
= d.createElement(%22div%22); b.style.width=N.width; b.style.height=N.height;
b.innerHTML=%22<del>%22 + t + %22</del>%22; N.parentNode.replaceChild(b,N); }
function Z(t) { var T = d.getElementsByTagName(t), i; for (i=T.length-1;i+1;--i)
K(T[i],t); } Z(%22object%22); Z(%22embed%22); Z(%22applet%22);
Z(%22iframe%22);})();">this bookmarklet</a> and click it AFTER the stupid ESPN
applet has settled down.
Comment 15 Bob Clary [:bc:] 2003-05-11 13:18:51 PDT
What issues are you seeing on the ESPN page which prevent it from being usable?
It works for me in a 2003 05 09 08 win2k build. Although they have an IE5+/Flash
only ESPNMotion thing.
Comment 16 Mike Schiraldi 2003-05-11 13:47:37 PDT
When ESPN.com's main page loads, i have a few seconds to click something and
have it work. As soon as the embedded ad at the top of the page "bounces", no
mouse clicks work inside the page anymore.

The only way i can interact with the document is to use the bookmarklet i posted
(sorry i put those HTML tags around it) -- it removes anything within <embed>
tags on a page.

I'm using an April 28 build under Linux.
Comment 17 Bob Clary [:bc:] 2003-05-11 13:49:55 PDT
Mike, that is probably a product bug under Linux. Can you file a bug on that and
cc me?
Comment 18 j lee 2003-05-11 15:28:35 PDT
I am having the same problem as Mike and I am using Windows XP. With Mike's
help, I have used the bookmarklet to disable the embedded flash in the espn.com
main page.

I am using the latest stable release, build 20030425.
Comment 19 Jason Bennett 2003-05-11 16:25:03 PDT
It's not Linux specific - I have the same problem on Win2k, Mozilla 1.4b
(2003050714). It happens every time they do the moving ad at the top.
Comment 20 jsnod 2003-05-11 21:53:06 PDT
Please see the original description for the original problem as described.  I
reported this over a year ago and it's still broken.  The problem is with the
individual team pages (eg: http://sports.espn.go.com/nhl/clubhouse?team=los),
not  the home page or any new banner ads, and if these new banner ads are
causing problems, perhaps they need a seperate evang bug filed.
Comment 21 foobarbaz99 2003-05-14 22:30:24 PDT
The problem of the links on the ESPN homepage not functioning after the 
annoying FLASH animation bounces away can also be solved by resizing the window,
even by the smallest amount

This works on Win2k. While this problem is also evident on Linux, I have not
tried the resizing solution on Linux.

Another symptom of the problem is that after the page stops functioning, you
can't move the window by left-clicking the titlebar. However, after a resize,
all functionality is restored.
Comment 22 Mike Pawka 2003-05-15 07:41:35 PDT
They seem to have fixed it for Mozilla
Comment 23 Micky Williamson 2003-05-22 09:01:48 PDT
As of May 22, using Firebird on Linux (Mozilla/5.0 (X11; U; Linux i686; en-US;
rv:1.4b) Gecko/20030516 Mozilla Firebird/0.6) the problem still exists with the
moving add on espn front page.
Comment 24 jsnod 2003-05-22 09:05:23 PDT
PLEASE READ the original Description!
This bug is not about problems with the moving add on the ESPN frontpage.
Comment 25 j lee 2003-05-22 09:27:29 PDT
It is my fault for bringing the moving "AD" issue to this bug. I have created a 
new bug that directly deals with this issue. Bug ID is 206760 so I'd appreciate 
if all of you with the moving ad lockup to leave comments on 206760.
Comment 26 Bob Clary [:bc:] 2003-06-12 07:29:40 PDT
tech evang june 2003 reorg
Comment 27 Steven Foster 2003-06-18 21:26:57 PDT
I was previously using the build from June 17, 2003 under Windows XP and
espn.com rendered perfectly.  I upgraded to 1.4RC2 and now it looks ugly again.
 I read here where it is the site's fault and I can understand that, but it
worked for a couple of days and now doesn't work again so I'm a bit skeptical of
that being the only thing wrong.  I had major problems tonight with just the
main http://espn.go.com/main.html URL.  But I'm pretty sure it rendered fine in
the previous nightly build just before I went to 1.4RC2.
Comment 28 Charles Fenwick 2003-06-19 19:17:18 PDT
Re: comment 27, espn.com's main page was FUBAR last night in nightly builds as
well as 1.4RC2.
Comment 29 Ed Kertz 2003-09-03 00:11:29 PDT
Sections of espn pages overlap or they are truncated.
Comment 31 Ian Barnett 2003-11-19 10:14:05 PST
I've read through a number of the "espn" related bugs. However, what no one has
mentioned in that Moz 1.4.x renders the ESPN Homepage http://espn.go.com
(almost) correctly. It is readable. However, 1.5 and 1.6a do not render the page
in any readable format. In fact, major sections of content are not loaded.

I've tried changing the User Agent string to simulate different browsers but the
behavior with 1.5 and 1.6 does not change.

Correct me if I'm wrong, but, how can this be an ESPN issue when the behavior is
not consistent with different Moz versions? 
Comment 32 jsnod 2003-11-19 10:23:19 PST
Well, if you'd read the original description of the bug, the problem is not with
the HOMEPAGE, it displays fine. The problem is with deeper pages, for example,
NHL team pages:

http://sports.espn.go.com/nhl/clubhouse?team=los

They are completely borked, sometimes completely unreadable (Text flowing
underneath images, etc).
Comment 33 jsnod 2004-02-05 14:32:52 PST
Created attachment 140696 [details]
Screencap of the problem

I've attached a screencap showing Mozilla 1.7a's rendering of
http://sports.espn.go.com/nhl/clubhouse?team=los right alongsize IE6.0's
rendering of the same page.  ESPN is huge, and this is a highly visible (and
embarassing) display problem that ESPN doesn't seem to want to fix.  Gives Moz
a bad name.
Comment 34 Frank Fridlund 2004-04-12 09:13:21 PDT
Adding to comment 33, the problem is the javascript.  If you turned off
javascript, or switched to the "clubhouse" stylesheet, then the page looks
similar to the IE picture (though some link colors on certain club pages may be
harder to read.)
Comment 35 jsnod 2004-06-11 08:59:06 PDT
Created attachment 150533 [details]
Screencap of Problem (Worse)

Can someone hit up ESPN to have this fixed before the 1.7/0.9 blitz?  It's
gotten worse, pages are unreadable, this top100 will make Mozilla look bad to
any potential converts.
Comment 36 jsnod 2004-07-02 19:14:10 PDT
This appears fixed in Firefox 0.9.1
Can someone confirm on the branch?
Comment 37 jsnod 2004-07-07 09:35:56 PDT
WFM on branch too -> Fixed.

Note You need to log in before you can comment on or make changes to this bug.