Closed Bug 1223934 Opened 7 years ago Closed 7 years ago

Stuck on FTE's wifi selection screen, can't get past it

Categories

(Firefox OS Graveyard :: Gaia::First Time Experience, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED INVALID

People

(Reporter: botond, Unassigned)

Details

(Whiteboard: [update gecko to > 2015-10-29])

Attachments

(1 file)

I built b2g for Aries and I'm trying to run it.

When the phone starts up, I see the first screen of the FTE app, and I can click Next on it. The next screen, which I believe is supposed to be the wifi selection screen, contains only a horizontal line, and a spinner underneath it, and is otherwise blank.

The spinner never stops spinning, and I can't get past this page. The home button doesn't do anything. The notification tray cannot be pulled down. Restarting the phone brings me back to the first screen of the FTE app.
Can you paste a logcat?
Can QA reproduce?
Keywords: qawanted
Attached file logcat
Maybe this one?
E/FTU     ( 1139): [JavaScript Error: "TypeError: document.l10n is undefined" {file: "app://ftu.gaiamobile.org/shared/js/tz_select.js" line: 145}]
E/FTU     ( 1139): fillSelectL10nElement@app://ftu.gaiamobile.org/shared/js/tz_select.js:145:7
E/FTU     ( 1139): fillRegions@app://ftu.gaiamobile.org/shared/js/tz_select.js:169:7
E/FTU     ( 1139): loadTZ@app://ftu.gaiamobile.org/shared/js/tz_select.js:223:7
E/FTU     ( 1139): tzSelect/loadJSON/xhr.onload@app://ftu.gaiamobile.org/shared/js/tz_select.js:21:7
Flags: needinfo?(gandalf)
Oh, indeed, my Gecko tree is based on m-c dated Oct 26!
QA cannot reproduce on today's Aries build. I was able to get through FTU without issue. And according to comment 5 and comment 6 this is user error.

No repro on:
Device: Aries 2.6 Master
BuildID: 20151111130110
Gaia: 22f8023b112dfae83531b0a075ab9eb9a5444dfa
Gecko: 84a7cf29f4f14c9b359db2f7f19c0abd6a8e178e
Gonk: a19052e4389c3ae2d8fc3e7a74a475401baacc56
Version: 45.0a1 (2.6) 
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:45.0) Gecko/45.0 Firefox/45.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmercado)
Keywords: qawanted
Confirmed that updating gecko solves the problem. Sorry for the noise.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → INVALID
Whiteboard: [update gecko to > 2015-10-29]
Flags: needinfo?(gandalf)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmercado)
You need to log in before you can comment on or make changes to this bug.