Updated German Holidays until 2025

RESOLVED WORKSFORME

Status

Calendar
Website
RESOLVED WORKSFORME
2 years ago
2 years ago

People

(Reporter: Fux, Unassigned)

Tracking

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
Created attachment 8686350 [details]
German Holidays 2010-2025

User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:42.0) Gecko/20100101 Firefox/42.0
Build ID: 20151029151421

Steps to reproduce:

I did an update to my outdated holiday file at https://www.mozilla.org/en-US/projects/calendar/holidays/#G (German), file is attachend.

Thanks for adding!
(Reporter)

Updated

2 years ago

Updated

2 years ago
Duplicate of this bug: 1219412

Updated

2 years ago
Duplicate of this bug: 1232319

Comment 3

2 years ago
Why does it take so long to get this onto the webpage? The current calendar is missing dates from 2016 which is about to begin.

Comment 4

2 years ago
Commit pushed to master at https://github.com/mozilla/bedrock

https://github.com/mozilla/bedrock/commit/5de7c20cff8e4d2d21fb1240993144b763ca0281
Update GermanHolidays.ics

Bug 1224067 - Updated German Holidays until 2025

Comment 5

2 years ago
Commit pushed to master at https://github.com/mozilla/bedrock

https://github.com/mozilla/bedrock/commit/cb696512e297a9359ba3c2bdbeb700313df541e1
Fix bug 1224067 - Updated German Holidays until 2025

Updated

2 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
Duplicate of this bug: 1235312

Comment 7

2 years ago
https://www.mozilla.org/media/caldata/GermanHolidays.ics is still not up-to-date, what's going on?

Comment 8

2 years ago
Hai ;-) Stephan,

this is the old file - Fux's attachment is correct!

Comment 9

2 years ago
Hi, ahh, ok, thanks, good thing Easter won't be cancelled this year after all :-)

Comment 10

2 years ago
High ;-) Stephan, 

no, God and Commissioner Oettinger haven't canceled Easter! If you need another calendars AT/CH/DE/LI (German) - blink to [https://www.thunderbird-mail.de/thread/72064-frische-kalender-f%C3%BCr-de-li-at-ch-2010-2030/]. My Calendars die in the queue named Bugzilla@Mozilla. 

I wish you a nuclear-free 2016!

Comment 11

2 years ago
(In reply to boe from comment #8)
> this is the old file - Fux's attachment is correct!

Eh... It was the whole point of this bug which is now resolved to update that file with the attachment here. Obviously that didn't work with the commit given in comment 5-- no idea why and no idea who told the github robot to do it, so no idea who to CC, but I'm reopening this bug. The webpage seems to be changed (it now says 2010-2025), just the file linked was not.
Status: RESOLVED → REOPENED
Ever confirmed: true
Resolution: FIXED → ---
The robot commented because the PR that Fux made was merged, see:


https://github.com/mozilla/bedrock/pull/3706
https://github.com/mozilla/bedrock/pull/3707

Fux has asked on the PR why this didn't work, I assume some sort of caching or production merge that needs to happen.
(Reporter)

Comment 13

2 years ago
Now it's working, thanks.

Fallen was right:

"These static files are served from a CDN and cached for 30 days, but we've purged the cache manually so the updated file should be serving now. Some browsers/clients may have their own cache, of course, so there's not much we can do about that.

We may shorten the expiration time for calendar files to just a few days so updates become available quicker in the future."
Status: REOPENED → RESOLVED
Last Resolved: 2 years ago2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.