[devtools] Do Not word-wrap labels on toolbar in Memory tool

RESOLVED FIXED in Firefox 45

Status

()

Firefox
Developer Tools: Memory
RESOLVED FIXED
3 years ago
2 years ago

People

(Reporter: magicp, Assigned: Sunny Sidhu, Mentored)

Tracking

(Blocks: 1 bug)

Trunk
Firefox 45
Points:
---

Firefox Tracking Flags

(firefox44 affected, firefox45 fixed)

Details

(Whiteboard: [good first bug][lang=css])

Attachments

(3 attachments, 1 obsolete attachment)

(Reporter)

Description

3 years ago
Created attachment 8686596 [details]
devtools-memory-word-wrap.png

User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:45.0) Gecko/20100101 Firefox/45.0
Build ID: 20151111030207

Steps to reproduce:

1. Run Nightly (or Aurora)
2. Open devtools > Memory
3. Firefox window width to narrow


Actual results:

Labels on toolbar is word-wrapped.


Expected results:

Do Not word-wrap labels on toolbar in Memory tool.
(Reporter)

Updated

3 years ago
Has STR: --- → yes
status-firefox44: --- → affected
status-firefox45: --- → affected
Component: Untriaged → Developer Tools: Memory
OS: Unspecified → All
Hardware: Unspecified → All
Blocks: 1221506

Comment 1

3 years ago
You need to add white-space: nowrap;overflow: hidden;text-overflow: ellipsis; here (with the correct indentation and line breaks): https://dxr.mozilla.org/mozilla-central/source/devtools/client/themes/memory.css#74 to fix this bug.
Mentor: ntim.bugs
Whiteboard: [good first bug][lang=css]
(Assignee)

Comment 2

3 years ago
Created attachment 8688355 [details] [diff] [review]
rev1 - Applies changes to fix word wrap in toolbar-group for devtools

Hi Tim, 

I've had a go at this. Please can you provide feedback on my patch?
Attachment #8688355 - Flags: feedback?(ntim.bugs)
(Assignee)

Comment 3

3 years ago
Created attachment 8688363 [details]
rev1_test.png

I've tested the changes using the Browser Toolbox, see attached.

Updated

3 years ago
Assignee: nobody → sidhus11

Updated

3 years ago
Status: NEW → ASSIGNED
(Reporter)

Comment 4

2 years ago
(In reply to Sunny Sidhu from comment #3)
> Created attachment 8688363 [details]
> rev1_test.png
> 
> I've tested the changes using the Browser Toolbox, see attached.

It seems snapshot icon is gone !?

Updated

2 years ago
Attachment #8688355 - Flags: review?(vporof)
Attachment #8688355 - Flags: feedback?(ntim.bugs)
Attachment #8688355 - Flags: feedback+
(Assignee)

Comment 5

2 years ago
Created attachment 8688958 [details]
rev2_test2.PNG

(In reply to magicp from comment #4)
> It seems snapshot icon is gone !?
Strange, I've no idea. All seems to be well on my re-test, see attached.
Attachment #8688363 - Attachment is obsolete: true
(Reporter)

Comment 6

2 years ago
(In reply to Sunny Sidhu from comment #5)
> Strange, I've no idea. All seems to be well on my re-test, see attached.
Your re-test is good. Thanks!
Attachment #8688355 - Flags: review?(vporof) → review+

Updated

2 years ago
Keywords: checkin-needed

Comment 9

2 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/e4fab7d5c909
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
status-firefox45: affected → fixed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 45
You need to log in before you can comment on or make changes to this bug.