Closed Bug 1224196 Opened 4 years ago Closed 4 years ago

[devtools] Do Not word-wrap labels on toolbar in Memory tool

Categories

(DevTools :: Memory, defect)

defect
Not set

Tracking

(firefox44 affected, firefox45 fixed)

RESOLVED FIXED
Firefox 45
Tracking Status
firefox44 --- affected
firefox45 --- fixed

People

(Reporter: magicp.jp, Assigned: sidhus11, Mentored)

References

(Blocks 1 open bug)

Details

(Whiteboard: [good first bug][lang=css])

Attachments

(3 files, 1 obsolete file)

User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:45.0) Gecko/20100101 Firefox/45.0
Build ID: 20151111030207

Steps to reproduce:

1. Run Nightly (or Aurora)
2. Open devtools > Memory
3. Firefox window width to narrow


Actual results:

Labels on toolbar is word-wrapped.


Expected results:

Do Not word-wrap labels on toolbar in Memory tool.
Has STR: --- → yes
Component: Untriaged → Developer Tools: Memory
OS: Unspecified → All
Hardware: Unspecified → All
You need to add white-space: nowrap;overflow: hidden;text-overflow: ellipsis; here (with the correct indentation and line breaks): https://dxr.mozilla.org/mozilla-central/source/devtools/client/themes/memory.css#74 to fix this bug.
Mentor: ntim.bugs
Whiteboard: [good first bug][lang=css]
Hi Tim, 

I've had a go at this. Please can you provide feedback on my patch?
Attachment #8688355 - Flags: feedback?(ntim.bugs)
Attached image rev1_test.png (obsolete) —
I've tested the changes using the Browser Toolbox, see attached.
Assignee: nobody → sidhus11
Status: NEW → ASSIGNED
(In reply to Sunny Sidhu from comment #3)
> Created attachment 8688363 [details]
> rev1_test.png
> 
> I've tested the changes using the Browser Toolbox, see attached.

It seems snapshot icon is gone !?
Attachment #8688355 - Flags: review?(vporof)
Attachment #8688355 - Flags: feedback?(ntim.bugs)
Attachment #8688355 - Flags: feedback+
Attached image rev2_test2.PNG
(In reply to magicp from comment #4)
> It seems snapshot icon is gone !?
Strange, I've no idea. All seems to be well on my re-test, see attached.
Attachment #8688363 - Attachment is obsolete: true
(In reply to Sunny Sidhu from comment #5)
> Strange, I've no idea. All seems to be well on my re-test, see attached.
Your re-test is good. Thanks!
Attachment #8688355 - Flags: review?(vporof) → review+
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/e4fab7d5c909
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 45
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.