bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

The cvar2 and socket tests hang on dual-processor Windows 2000.

RESOLVED WONTFIX

Status

NSPR
NSPR
P1
normal
RESOLVED WONTFIX
17 years ago
11 years ago

People

(Reporter: Wan-Teh Chang, Assigned: Wan-Teh Chang)

Tracking

4.1.2
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

17 years ago
I discovered this problem while testing NSPR 4.2 Beta 1, and
to my surprise, found that this problem also exists in NSPR
4.1.2.

I have only seen this problem with the WINNT optimized build
on my dual-processor Windows 2000 box.  The symtom is that the
cvar2 and socket tests hang intermittently.  It is not hard to
make these two tests hang.  If you run these tests repeatedly,
they will usually hang in fewer than 10 tries.

It is difficult to debug this problem because they only occur
with the optimized build.  I found that by disabling "global
optimization" (the -Og- compiler flag) on ntio.c, I can make
the problem go away.  So the problem is probably in that file.
(Assignee)

Updated

17 years ago
Status: NEW → ASSIGNED
Priority: -- → P1
Target Milestone: --- → 4.2
(Assignee)

Comment 1

17 years ago
Created attachment 69288 [details] [diff] [review]
Workaround: disables global optimization on ntio.c

I found that if I disable global optimization (-Og-) on ntio.c,
and only ntio.c, the problem is gone.

I've checked this workaround into the tip of NSPR.

Comment 2

12 years ago
Was this with VC++ 7.0 or 7.1? This seems like a pretty serious bug, not sure why it's still open :(
(Assignee)

Comment 3

12 years ago
This was with MSVC 6.  I don't remember which service pack
level it was at.  Most likely SP4 or later.

Comment 4

12 years ago
I have a Win2000 dual processor box and have seen hanging behavior with VC++ 6.0.  Apparently its still happening. I'll try to get a fresh build and run the tests.
QA Contact: wtchang → nspr

Comment 5

11 years ago
The target milestone is already released. Resetting target milestone.
Target Milestone: 4.2 → ---

Comment 6

11 years ago
Does anybody have the stack trace for the hanging thread?
Also, is this issue fixed on 4.2.2?
I propose that we consider this bug to have been fixed by the workaround
that was committed 5+ years ago.  
The workaround was committed for NSPR 4.2, and has been present in 
that version and all higher numbered versions.
Target Milestone: --- → 4.2
(Assignee)

Updated

11 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.