Only highlight element when searching instead of selecting it

RESOLVED DUPLICATE of bug 1259390

Status

()

Firefox
Developer Tools: Inspector
--
enhancement
RESOLVED DUPLICATE of bug 1259390
2 years ago
2 years ago

People

(Reporter: sebo, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
Instead of selecting the matched element when searching within the Inspector panel, the match should only be highlighted like it's done in other panels with search capability.

Sebastian
One of the important features of the search tool in the inspector is, in fact, to quickly navigate to a node, so if you only highlight but don't select, then that feature is gone.

Why would you not want to select elements when searching?

(ccing Brian who's been working on the search tool recently).
(Reporter)

Comment 2

2 years ago
(In reply to Patrick Brosset [:pbrosset] [:pbro] from comment #1)
> Why would you not want to select elements when searching?

In the case you want to keep the existing selection but just search for another element e.g. for comparison or if you just want to search by text.
Or you only want to select the right element. E.g. you search for class 'test', several elements within your page match it, though you only want to select the last one. This would have the advantage that the subtree containing the previous match could be closed again.

> One of the important features of the search tool in the inspector is, in
> fact, to quickly navigate to a node, so if you only highlight but don't
> select, then that feature is gone.

I know. This would need to be reached differently then, e.g. by an additional shortcut like Ctrl+Enter or something.

Sebastian
See Also: → bug 1259390
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1259390
You need to log in before you can comment on or make changes to this bug.