Closed Bug 1224548 Opened 6 years ago Closed 6 years ago

[Aries] test_gallery_switch_to_camera.py and test_gallery_switch_to_camera_main_view.py fail: TimeoutException: TimeoutException: Timed out after 30.2 seconds

Categories

(Firefox OS Graveyard :: Gaia::UI Tests, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: u504868, Assigned: u504868)

References

Details

> Traceback (most recent call last):
> File "/var/jenkins/1/workspace/aries.mozilla-central.nightly.ui.functional.smoke/.env/local/lib/python2.7/site-packages/marionette_client-1.0.0-py2.7.egg/marionette/marionette_test.py", line 296, in run
> testMethod()
> File "/var/jenkins/1/workspace/aries.mozilla-central.nightly.ui.functional.smoke/tests/python/gaia-ui-tests/gaiatest/tests/functional/gallery/test_gallery_switch_to_camera.py", line 44, in test_gallery_switch_to_camera
> Wait(self.marionette).until(lambda m: len(self.data_layer.picture_files) ==
> File "/var/jenkins/1/workspace/aries.mozilla-central.nightly.ui.functional.smoke/.env/local/lib/python2.7/site-packages/marionette_driver-1.0.0-py2.7.egg/marionette_driver/wait.py", line 143, in until
> cause=last_exc)
> TimeoutException: TimeoutException: Timed out after 30.1 seconds



> Traceback (most recent call last):
> File "/var/jenkins/1/workspace/aries.mozilla-central.nightly.ui.functional.smoke/.env/local/lib/python2.7/site-packages/marionette_client-1.0.0-py2.7.egg/marionette/marionette_test.py", line 296, in run
> testMethod()
> File "/var/jenkins/1/workspace/aries.mozilla-central.nightly.ui.functional.smoke/tests/python/gaia-ui-tests/gaiatest/tests/functional/gallery/test_gallery_switch_to_camera_main_view.py", line 37, in test_gallery_view
> Wait(self.marionette).until(lambda m: len(self.data_layer.picture_files) ==
> File "/var/jenkins/1/workspace/aries.mozilla-central.nightly.ui.functional.smoke/.env/local/lib/python2.7/site-packages/marionette_driver-1.0.0-py2.7.egg/marionette_driver/wait.py", line 143, in until
> cause=last_exc)
> TimeoutException: TimeoutException: Timed out after 30.2 seconds
Blocks: 1181535
The problem here is because gallery stores a preview on the SD card itself. So we start the test with 2 filed detected by self.data_layer.picture_files (the preview and the real image). Then when the wait happens, we created a new couple (preview + image), which makes 4 images, but the expected value is 3.
just as a sanity check, dhylands, this is a newly expected behavior in MTP mode in Aries?
Flags: needinfo?(dhylands)
FWIW, the reports stored in Jenkins show this change happened between Oct 8th and Oct 14th 2015.
There was a change in the MTP code on Oct 13th. See bug 1205028 

Its not clear to me that change would cause anything here, but it's probably worth looking into.
Flags: needinfo?(dhylands)
Gaia UI tests are not run or maintained anymore.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.