Closed Bug 1224600 Opened 4 years ago Closed 4 years ago

utf-8 + comma in To line breaks File | Send Unsent Messages

Categories

(MailNews Core :: Backend, defect)

defect
Not set

Tracking

(thunderbird45+ fixed, thunderbird46 fixed, seamonkey2.39 affected)

RESOLVED FIXED
Thunderbird 46.0
Tracking Status
thunderbird45 + fixed
thunderbird46 --- fixed
seamonkey2.39 --- affected

People

(Reporter: jik, Assigned: mkmelin)

Details

Attachments

(1 file)

1. Create an address book entry with a display name in the form "Lastname, Firstname" where "Lastname" has a utf-8 character in it, e.g., "Fréédle, Froodle".

2. Compose a message to that recipient using address auto-completion.

3. File | Send Later.

4. In main window, File | Send Unsent Messages.

You will see: "There are non-ASCII characters in the local part of the recipient address . This is not yet supported. Please change this address and try again."
Status: NEW → UNCONFIRMED
Ever confirmed: false
Shouldn't mime-decode when setting the compose fields. If we do then for comma-display-names we get something decoded that doesn't have quoted display name -> gets taken as two mailboxes later on -> one of the "two mailboxes" don't have an address -> you get the error message.

(The error message is misleading of course, I'll see to that in another bug.)

The display names aren't actually used for anything after this as only the addresses are used on the protocol level.
Assignee: nobody → mkmelin+mozilla
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Attachment #8706035 - Flags: review?(rkent)
Comment on attachment 8706035 [details] [diff] [review]
bug1224600_utf8_comma_unsent.patch

Review of attachment 8706035 [details] [diff] [review]:
-----------------------------------------------------------------

See bug 152690 for the original code that inserted this. I could not reproduce the issue in that bug after the current patch is implemented, so something must have changed. So let's try this.
Attachment #8706035 - Flags: review?(rkent) → review+
https://hg.mozilla.org/comm-central/rev/695cfc9ef250 -> FIXED
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 46.0
Comment on attachment 8706035 [details] [diff] [review]
bug1224600_utf8_comma_unsent.patch

Review of attachment 8706035 [details] [diff] [review]:
-----------------------------------------------------------------

Should land on auroara45 after trunk baking.
Attachment #8706035 - Flags: approval-comm-aurora?
Does this need to be ported to SeaMonkey or does SeaMonkey get mailnews/compose fixes automatically?
mailnews/ is shared code so it's automatic
Attachment #8706035 - Flags: approval-comm-aurora? → approval-comm-aurora+
You need to log in before you can comment on or make changes to this bug.