Sending Email Notification bar is empty without text

VERIFIED FIXED

Status

Firefox OS
Gaia::E-Mail
VERIFIED FIXED
2 years ago
2 years ago

People

(Reporter: VladimirBelonenko, Assigned: jrburke)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(blocking-b2g:2.6?, b2g-v2.2 unaffected, b2g-v2.5 unaffected, b2g-master verified)

Details

(Whiteboard: [2.5-Daily-Testing][Spark], URL)

Attachments

(4 attachments)

(Reporter)

Description

2 years ago
Created attachment 8687383 [details]
logcat_20151113_1258.txt

Description:
When sending an email a user should see a notification bar with text 'Email is Send' not empty notification.

Repro Steps:
1) Update a Aries to 20151113123209
2) Open E-mail app
3) Send new message or reply.
4) Observe that sending email notification has no text inside its blank.

Actual:
Notification bar is empty without a text when you send an email.

Expected:
Notification bar should display text 'Email send',

Environmental Variables:
Device: Aries Master 2.6 kk full flash
Build ID: 20151113123209
Gaia: e8c15ae4e5324a210000ee0a869a962aa542009f
Gecko: faf815a0fa9b052a38bce00c0c2aa1e2c9610936
Gonk: a19052e4389c3ae2d8fc3e7a74a475401baacc56
Version: 45.0a1 (Master)
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:45.0) Gecko/45.0 Firefox/45.0

Repro frequency: 3/3
See attached: video clip and log cat
(Reporter)

Comment 1

2 years ago
This issue still occurs on Flame 2.6
Result: Notification bar is empty without a text when you send an email.

Environmental Variables:
Device: Flame 2.6 kk full flash
Build ID: 20151113030210
Gaia: e8c15ae4e5324a210000ee0a869a962aa542009f
Gecko: 0eaf345983b3afc2b426e25a3be93ebf0d93e6c1
Gonk: 205ac4204bbbb2098a8046444acba551ba5dc75a
Version: 45.0a1
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:45.0) Gecko/45.0 Firefox/45.0

This issue does not occur on Flame 2.5 and Flame 2.2
Result: Notification bar displayed text 'Email sent'.

Environmental Variables:
Device: Flame 2.5 kk full flash
Build ID: 20151105004500
Gaia: 47da49f8206788d70d834c3a63d9245d50c89103
Gecko: 5c9fd135d4309239794126f1942d6e7aa8b3579c
Gonk: 205ac4204bbbb2098a8046444acba551ba5dc75a
Version: 45.0a1
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:45.0) Gecko/45.0 Firefox/45.0

Environmental Variables:
Device: Flame 2.2
Build ID: 20151113032509
Gaia: 885647d92208fb67574ced44004ab2f29d23cb45
Gecko: e772f343b736
Gonk: bd9cb3af2a0354577a6903917bc826489050b40d
Version: 37.0 (2.2)
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
QA Whiteboard: [QAnalyst-Triage+]
status-b2g-v2.2: --- → unaffected
status-b2g-v2.5: --- → unaffected
status-b2g-master: --- → affected
Flags: needinfo?(ktucker)
Keywords: regression
blocking-b2g: --- → 2.6?
QA Whiteboard: [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
Keywords: regressionwindow-wanted
This bug can't be repro anymore on latest build of Flame KK v2.6 (master) 512mb and Aries KK v2.6 (master). I'm not sure whether still need to do the regression window. So leaving the   "regressionwindow-wanted" for reproduction in the future.

Actual results: Notification bar can display text 'Email send'.
See attachment: Flame_v2.6.3gp.
Reproduce rate: 0/10. 

Device: Flame KK v2.6 master 512mb 
Build ID               20151117150203
Gaia Revision          28d63cf3bdc4417f7ad8cab2230f096bf9f6d3b5
Gaia Date              2015-11-17 07:35:12
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/8c3a0b58fd51c02c8aca138b0da58445becb037f
Gecko Version          45.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20151117.183602
Firmware Date          Tue Nov 17 18:36:15 EST 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

Device: Aries KK 2.6 master 
Build ID               20151117222127
Gaia Revision          28d63cf3bdc4417f7ad8cab2230f096bf9f6d3b5
Gaia Date              2015-11-17 07:35:12
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/8c3a0b58fd51c02c8aca138b0da58445becb037f
Gecko Version          45.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20151117.214032
Firmware Date          Tue Nov 17 21:40:40 UTC 2015
Bootloader             s1
Created attachment 8688858 [details]
Flame_v2.6.3gp

Updated

2 years ago
Summary: Sending Email Notification bar is empty without text. → Sending Email Notification bar is empty without text

Comment 4

2 years ago
Removing regressionwindow-wanted tag as this issue has already been resolved on Aries Master

Result: After replying or forwarded a message the email page will go to the user's inbox with the chime successfully indicating the message has been sent. No blank email message appears.

Environmental Variables:
Device: Aries 2.6 Kk
BuildID: 20151118151339
Gaia: cba7e4b86361af31b153cfebaf99900e0b860f7b
Gecko: 1d6155d7e6c91fa5ec1ef6927f3d3a044187896d
Gonk: a19052e4389c3ae2d8fc3e7a74a475401baacc56
Version: 45.0a1 (2.6) 
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:45.0) Gecko/45.0 Firefox/45.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmercado)
Keywords: regressionwindow-wanted
Teri this issue no longer reproduces, are we ok to close it as WFM?
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmercado) → needinfo?(twen)

Comment 6

2 years ago
Yes, close as WFM.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(twen)
Resolution: --- → WORKSFORME

Comment 7

2 years ago
I'm still seeing this on the latest master (2.6) build on Aries.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
I've been seeing this for a few weeks as well, and I updated to a master build from last night, and still see it.
(Assignee)

Updated

2 years ago
Assignee: nobody → jrburke
Status: REOPENED → ASSIGNED

Comment 9

2 years ago
Created attachment 8695673 [details] [review]
[gaia] jrburke:bug1224701-email-notification-bar > mozilla-b2g:master
(Assignee)

Comment 10

2 years ago
Comment on attachment 8695673 [details] [review]
[gaia] jrburke:bug1224701-email-notification-bar > mozilla-b2g:master

Another thing I missed when reviewing bug 1223275, the in-app toast expects the localized string to already be available. This uses the same async API in bug 1223275 to retrieve the text before sending it out in the data structure expected by message_list's onBackgroundSendStatus.
Attachment #8695673 - Flags: review?(bugmail)
Attachment #8695673 - Flags: review?(bugmail) → review+
(Assignee)

Updated

2 years ago
Duplicate of this bug: 1229912
(Assignee)

Comment 12

2 years ago
Merged in Gaia master:
https://github.com/mozilla-b2g/gaia/commit/e08f03ec5e8630a9ea502f7ff7e8e921c69039f7
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago2 years ago
Resolution: --- → FIXED
This bug has been verified as pass on latest build of Flame KK master 512mb and Aries KK master by the STR in comment 0.
Actual results: Notification bar can display text 'Email send'.
See attachment: Verified_Aries_master.3gp.
Reproduce rate: 0/10.

Device: Flame KK master 512mb  (Pass)
Build ID               20151206150208
Gaia Revision          b930e25e9f2e5ec2106dd31005468575cdf87d50
Gaia Date              2015-12-05 03:41:55
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/cc9c6cd756cb744596ba039dcc5ad3065a7cc3ea
Gecko Version          45.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20151206.184313
Firmware Date          Sun Dec  6 18:43:25 EST 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

Device: Aries KK master (Pass)
Build ID               20151206002630
Gaia Revision          b930e25e9f2e5ec2106dd31005468575cdf87d50
Gaia Date              2015-12-05 03:41:55
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/cc9c6cd756cb744596ba039dcc5ad3065a7cc3ea
Gecko Version          45.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20151205.234548
Firmware Date          Sat Dec  5 23:45:56 UTC 2015
Bootloader             s1
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][MGSEI-Triage+]
status-b2g-master: affected → verified
Created attachment 8696407 [details]
Verified_Aries_master.3gp
You need to log in before you can comment on or make changes to this bug.