[FlameKK] After OTA all bookmark icons appear as placeholder rocketship icons

RESOLVED DUPLICATE of bug 1222340

Status

Firefox OS
Gaia::Homescreen
RESOLVED DUPLICATE of bug 1222340
2 years ago
2 years ago

People

(Reporter: KTucker, Unassigned)

Tracking

(Blocks: 1 bug)

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:2.5+, b2g-master affected)

Details

(Whiteboard: [2.6-Daily-Testing][Spark][systemsfe])

Attachments

(2 attachments)

Created attachment 8687426 [details]
rocketships.png

When the user bookmarks websites to their homescreen on Flame 2.2 and then updates to 2.6, they will notice that their bookmarks will appear as placeholder "rocketship" icons.

Repro Steps:
1) Flash the Flame to base image v18D v4.
2) Shallow flash to Flame 2.2 build 20151113032509
3) After flashing, open the browser app.
4) Visit different websites, bookmarking those websites to the home screen.
5) Pay close attention to the bookmark icons on the home screen and perform an OTA to the latest Flame 2.6 build. 
6) Scroll down the home screen after updating and look at the bookmarks that were added from the Flame 2.2 build.

Actual:
All bookmark icons will appear as placeholder "rocketship" icons on the home screen after OTA.

Expected:
All user created bookmarks retain their original icons and do not appear as "rocketship" icons on the home screen. 

Environmental Variables:
Device: Flame 2.6 (512mb)(KK)
Build ID: 20151113030210
Gaia: e8c15ae4e5324a210000ee0a869a962aa542009f
Gecko: 0eaf345983b3afc2b426e25a3be93ebf0d93e6c1
Gonk: 040bb1e9ac8a5b6dd756fdd696aa37a8868b5c67
Version: 45.0a1 (2.6)
Firmware Version: v18D v4
User Agent: Mozilla/5.0 (Mobile; rv:45.0) Gecko/45.0 Firefox/45.0
(Reporter)

Updated

2 years ago
status-b2g-master: --- → affected
Whiteboard: [2.6-Daily-Testing][Spark]
Created attachment 8687434 [details]
logcat_20151113_1502.txt
(Reporter)

Updated

2 years ago
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmercado)
(Reporter)

Updated

2 years ago
Blocks: 1224758
(Reporter)

Updated

2 years ago
No longer blocks: 1224758
(Reporter)

Updated

2 years ago
Summary: After OTA all bookmark icons appear as placeholder rocketship icons → [FlameKK] After OTA all bookmark icons appear as placeholder rocketship icons
(Reporter)

Updated

2 years ago
Blocks: 1224750
[Blocking Requested - why for this release]:

All icons becomeing rocketship icons would severely impair usage of the phone.

Alison can I get your opinion as well.
blocking-b2g: --- → 2.5?
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmercado) → needinfo?(ashiue)

Comment 3

2 years ago
This is really a bad user experience.

Hi Gregor,

Could you please dispatch this issue to suitable person to help check? Thank you.
Flags: needinfo?(ashiue) → needinfo?(anygregor)
Whiteboard: [2.6-Daily-Testing][Spark] → [2.6-Daily-Testing][Spark][systemsfe]

Comment 4

2 years ago
Probably a dupe of bug 1222340 (and a regression).
Component: Gaia::Bookmark → Gaia::Homescreen
blocking-b2g: 2.5? → 2.5+
Flags: needinfo?(anygregor)

Updated

2 years ago
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1222340
You need to log in before you can comment on or make changes to this bug.