Pinned YouTube and Facebook sites will display Rocket Ship icon on the Homescreen instead of proper site icon.

RESOLVED DUPLICATE of bug 1222340

Status

Firefox OS
Gaia::Homescreen
RESOLVED DUPLICATE of bug 1222340
2 years ago
2 years ago

People

(Reporter: Marty, Unassigned)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(b2g-v2.5 unaffected, b2g-master affected)

Details

(Whiteboard: [2.6-Daily-Testing][Spark])

Attachments

(2 attachments)

(Reporter)

Description

2 years ago
Created attachment 8687450 [details]
logcat_pin-site.txt

Description:
If the user pins YouTube or Facebook as a Site to the homescreen, it will display as a rocket ship icon, instead of the proper site icon.

-The is the only websites I have found to do this are Facebook and YouTube.
-CNN, Twitter, Google, Pinterest, Reddit, and Imgur all properly display their site icon.

Repro Steps:
1) Update a Aries to 20151113123209
2) Open the Browser app and navigate to YouTube.com
3) Select the ellipsis (...) and Pin the Site
4) Return to the Homescreen
5) Repeat steps 2-4 with Facebook.com

Actual:
Facebook and YouTube display as Rocket ship icons

Expected:
Popular sites display the proper site icon when pinned to the homescreen

Environmental Variables:
Device: Aries 2.6
Build ID: 20151113123209
Gaia: e8c15ae4e5324a210000ee0a869a962aa542009f
Gecko: faf815a0fa9b052a38bce00c0c2aa1e2c9610936
Gonk: a19052e4389c3ae2d8fc3e7a74a475401baacc56
Version: 45.0a1 (2.6)
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:45.0) Gecko/45.0 Firefox/45.0

Repro frequency: 8/8
See attached: Screenshot, Logcat
(Reporter)

Comment 1

2 years ago
Created attachment 8687452 [details]
Youtube-Pin-Screenshot.png
(Reporter)

Comment 2

2 years ago
This issue DOES occur on the latest Flame 2.6 build.
Facebook and Youtube display as Rocket ship icons

Environmental Variables:
Device: Flame 2.6
BuildID: 20151113030210
Gaia: e8c15ae4e5324a210000ee0a869a962aa542009f
Gecko: 0eaf345983b3afc2b426e25a3be93ebf0d93e6c1
Gonk: 205ac4204bbbb2098a8046444acba551ba5dc75a
Version: 45.0a1 (2.6) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:45.0) Gecko/45.0 Firefox/45.0


*************************************

This issue does NOT occur on the latest Flame 2.5 build.
Facebook and Youtube display the proper site icons.

Environmental Variables:
Device: Flame 2.5
BuildID: 20151109004552
Gaia: cf646c52bb947af28329b0a100df91d1b1f2a907
Gecko: 4eafef5b80f8985c94c4a067f130d37513e1a581
Gonk: 205ac4204bbbb2098a8046444acba551ba5dc75a
Version: 44.0a2 (2.5) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:44.0) Gecko/44.0 Firefox/44.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
Keywords: regressionwindow-wanted
QA Whiteboard: [QAnalyst-Triage+]

Updated

2 years ago
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1222340
Removing regression window tag.
Keywords: regressionwindow-wanted
You need to log in before you can comment on or make changes to this bug.