Closed Bug 1224908 Opened 6 years ago Closed 6 years ago

"Show Tabs" button no longer has an accessibility label

Categories

(Firefox for iOS :: Browser, defect)

All
iOS 9
defect
Not set
normal

Tracking

()

RESOLVED FIXED
Tracking Status
fxios 1.3+ ---

People

(Reporter: dusek, Assigned: dusek)

References

(Blocks 1 open bug)

Details

(Keywords: access)

Attachments

(1 file)

48 bytes, text/x-github-pull-request
st3fan
: review+
Details | Review
With VoiceOver on:

Steps to Reproduce:
1. Open Firefox
2. Move VO cursor to the tabs button (in the top bar, just after the address text field/label)
3. Hear what VO says

Expected Results:
VO says "Show tabs, 1, button" 

Actual Results:
VO says "1, button"

Notes:
I guess (without verifying) accessibilityValue is correctly at "1", but accessibilityLabel somehow disappeared and is nil or "" instead of "Show Tabs"
Status: NEW → ASSIGNED
Attached file Pull Request
Attachment #8687687 - Flags: review?(sarentz)
Comment on attachment 8687687 [details] [review]
Pull Request

LGTM
Attachment #8687687 - Flags: review?(sarentz) → review+
Since this has a patch, lets move this to 1.3.

Note that we need to land this on both master and the 1.x branch.
Would it make sense to just wait until we make the cut and curate the bugs from the tracking-fxios list instead of uplifting it now?
Rank: 1
Whiteboard: [needsuplift]
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Whiteboard: [needsuplift]
You need to log in before you can comment on or make changes to this bug.