Closed Bug 1224966 Opened 5 years ago Closed 5 months ago

Code on developer.mozilla.org/en-US/docs/Web/API/SubtleCrypto/deriveKey will not run, has many bugs

Categories

(Developer Documentation Graveyard :: General, defect, P3)

defect

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: dbkats, Assigned: wbamberg)

References

Details

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.10; rv:42.0) Gecko/20100101 Firefox/42.0
Build ID: 20151029151421

Steps to reproduce:

navigate to https://developer.mozilla.org/en-US/docs/Web/API/SubtleCrypto/deriveKey
take code, put into latest firefox, run

Code has typos and undefined variables. Makes reference to Unibabel rather than standard TextEncoder API.


Actual results:

aborted with errors


Expected results:

should run without errors
Summary: Code on this page will not run, has many bugs → Code on developer.mozilla.org/en-US/docs/Web/API/SubtleCrypto/deriveKey will not run, has many bugs
Hi.

I can confirm this bug. Tried to fix issues to get it running, but the "var proofOfSecret" seems to be empty. Maybe someone can fix this to get the sample working as expected?

Regards.
Assignee: nobody → wbamberg
Priority: -- → P3
MDN Web Docs' bug reporting has now moved to GitHub. From now on, please file content bugs at https://github.com/mdn/sprints/issues/ and platform bugs at https://github.com/mdn/kuma/issues/.
Status: UNCONFIRMED → RESOLVED
Closed: 5 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.