The characters are displayed garbled in pop-up window on many web sites.

NEW
Unassigned

Status

()

P3
major
17 years ago
7 years ago

People

(Reporter: amyy, Unassigned)

Tracking

({intl})

Trunk
mozilla1.0
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(7 attachments)

(Reporter)

Description

17 years ago
Build: 01-29 trunk build on WinXP-JA, Linux7.1-JA, Mac OS 10.1
Also reproduce on Win98-KO.

When loading page http://www.joins.com/ there will be a small pop-up window
appear, notice part of the characters including a button and title will
displayed garbled, it also can be seen on Win98-KO.
(Reporter)

Comment 1

17 years ago
Created attachment 67006 [details]
screen shot for the window
(Reporter)

Updated

17 years ago
Keywords: intl
QA Contact: ruixu → ylong

Comment 2

17 years ago
See bug 122532 for another case.
(Reporter)

Comment 3

17 years ago
-> nsbeta1, a lots of pop-up windows has this problem.
Severity: normal → major
(Reporter)

Updated

17 years ago
Keywords: nsbeta1
(Reporter)

Comment 4

17 years ago
Created attachment 69791 [details]
screen shot for 163.com pop-up window garbled title

See another example on one of the most top SimpChinese web site pop-up window
on SimpChinese WinXP.

IE display fine.
(Reporter)

Comment 5

17 years ago
Since this is not only existing on this Korean page, modified the sumarry.

And there is no way that we can change the pop-up charset. 
Summary: The Korean characters are displayed garbled in joins.com pop-up window → The characters are displayed garbled in pop-up window on many web sites.

Updated

17 years ago
Status: NEW → ASSIGNED
Target Milestone: --- → mozilla1.0

Comment 6

17 years ago
There isn't much we can do for the window title. So forget
about it.

Charset for popup window, however, we may be able to do something.

Comment 7

17 years ago
ylong: can you try this again?  I believe we fixed this. 
It's hard to reproduce since the contents in URL are 
changing everyday.  I tried the chinese link from 122532
and popups shows ok.
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 8

17 years ago
The original pages are not showing the pop-up window right now.  However the
problem still existing.

Here is a new URL:
http://astro.sina.com.cn/t/2001-09-03/1512.shtml

The pop-up window will show garbled, and IE is showing file.  

I'm re-open it.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
(Reporter)

Comment 9

17 years ago
Created attachment 70824 [details]
Saved the source page.

Looks like the main page and the pop-up window are both encoding as gb2312.

Comment 10

17 years ago
nsbeta1+ per i18n triage
Keywords: nsbeta1 → nsbeta1+

Comment 11

17 years ago
Reassign to ftang.
Assignee: yokoyama → ftang
Status: REOPENED → NEW

Comment 12

17 years ago
it looks like caused by 125315 and 125317
Status: NEW → ASSIGNED
Depends on: 125315, 125317

Updated

17 years ago
No longer depends on: 125315

Comment 13

17 years ago
There are two problems in the saved test cases, one is the meta tag issue. The
other is the following code in the javascript
 if(navigator.appName.indexOf("Netscape") != -1)
 	{
 
	str[i] = str[i].replace(/"/g,"""); 
 
	str[i]=getEscapeValue(str[i]);
 	}


Comment 14

17 years ago
I use 2002031103 window build
1. www.joins.com show me no popup window
2. www.163.com show me no popup window
3. http://astro.sina.com.cn/t/2001-09-03/1512.shtml - the problem is still
there. I think the is the same problem that harishd is current fixing. for js
generate meta charset .

momoi- can you take a look at that javascript. I think there are some intl
special TE/DS issue there. 

Comment 15

17 years ago
P3
Priority: -- → P3

Updated

17 years ago
Whiteboard: adt1
Changing to ADT3 per ADT triage. The main image in the pop-up looks fine, and
this bug only affects windows title bars for the most part.
Whiteboard: adt1 → [ADT3]
(Reporter)

Comment 17

17 years ago
Created attachment 76802 [details]
Another contains garbled in pop-up window

On http://www.milkyway.com.cn

There are 2 links(cisco and microsoft) will get garbled displayed inside pop-up
window.

Comment 18

17 years ago
> On http://www.milkyway.com.cn

> There are 2 links(cisco and microsoft) will get garbled displayed inside pop-up
> window.

Can we separate the issues we must solve from those that have to do with 
browser setting? The pops on http://www.milkyway.com.cn will be viewed OK 
as GB2312 if you have GB2312 as the default browser setting at minimum. 
If you have also Chinese or Simplified Chinese auto-detection ON, it 
works even better.

The problem with the pop ups on the milkway page is that these pop ups
don't have its own encoding specification.
If we inherited the parent window encoding in such a case, it should
work for most cases. Roy, I thought we are doing that? Are we placing
the default pref encoding above the inherited encoding?

Comment 19

17 years ago
> Are we placing the default pref encoding above the inherited encoding
No. We inherite encoding from the parent in the _browser_ case.  
I believe we use JavaScript to set the encoding.  
Popup window is a different issue, I think.

Comment 20

17 years ago
> I believe we use JavaScript to set the encoding.  
> Popup window is a different issue, I think.

Why is this? Is it because the code does not handle this latter as the
same as the first case? From a user's point of view, a pop up is the same as
opening a new window from the current window. Can we deal with it the same
way?

Comment 21

17 years ago
>Changing to ADT3 per ADT triage. The main image in the pop-up 
>looks fine, and this bug only affects windows title bars for the
> most part.
No, the biggest problem is in the lower end of the pop up window, there are some
text and a button. And they are garbage. 

The cases that ylong later show about chinese are not the same problem. Those
can be fixed by changing the encoding menu, but in other cases- such as the one
in the attachement 3, it have no work around untill we fix the parser.

backup jaimejr's [ADT3] to adt1.


Impact Summery
Impact Platform: ALL
Impact language users: 100% all internet users.
Probability of hitting the problem: High, we see major web sites have this issue.
Severity if hit the problem in the worst case: User cannot read the text
Way of recover after hit the problem: None
Risk of the fix: Unknown, Probably Med
Potential benefit of fix this problem: Fix other meta bug issues.
Whiteboard: [ADT3] → adt1

Updated

17 years ago
Whiteboard: adt1 → [adt1]

Comment 22

17 years ago
We probably want to move the title bar problem to a new bug.

And I think we can do a better job in the title bar on W2K and XP (not sure
about NT) because those OSes have better Unicode support.  I believe IE
displays titles correctly in these cases.  Can someone verify?

There's not much we can do for displaying non-native titles on Win9x, but
we could fix it for the newer MS Windows.  
(Reporter)

Comment 23

17 years ago
> There's not much we can do for displaying non-native titles on Win9x

This bug is for titles on native OS.

Comment 24

17 years ago
I put adt1 for :
http://astro.sina.com.cn/t/2001-09-03/1512.shtml
not for the title problem. 

Comment 25

17 years ago
The part which blocking the fix for  this problem will be addressed by bug
125317. After the 125317, we won't see blank window when we try
http://bugzilla.mozilla.org/attachment.cgi?id=70824&action=view
however, we will see garbage text. 
The garbage text is produced by hacky javascript and should be addressed as
TE/DS support issue. I will attach a diff which remove the webside hack that
make it work with Mozilla after harishd land 125317. After harishd land 125317,
we should take out the adt1 and reassign this bug to momoi as TE/DS issue for  

http://astro.sina.com.cn/t/2001-09-03/1512.shtml

Comment 26

17 years ago
the [adt1] and nstbeta1+ part are fixed by 125135 and 125317. the remainning
part are not nsbeta1+ but TE/DS issue.
remove [adt1]. change nsbeta1+ to nsbeta1-
Keywords: nsbeta1+ → nsbeta1-
Whiteboard: [adt1]

Comment 27

17 years ago
Created attachment 80469 [details] [diff] [review]
diff to fix the web page

Comment 28

14 years ago
what a hack. I have not touch mozilla code for 2 years. I didn't read these bugs
for 2 years. And they are still there. Just close them as won't fix to clean up.
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago14 years ago
Resolution: --- → WONTFIX

Comment 29

14 years ago
Mass Bug Re-Open of bugs Frank Tang Closed with no good reason. Spam is his
fault not my own
Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---

Comment 30

14 years ago
Mass Re-assinging Frank Tangs old bugs that he closed won't fix and had to be
re-open. Spam is his fault not my own
Assignee: ftang → nobody
Status: REOPENED → NEW
QA Contact: amyy → i18n
Created attachment 620621 [details]
suspected virus activity

some sites give this cluttered with chinese/japanese characters instead of correct page eg.http://www.ribbonsoft.com/qcad.html gives this type of web page
Created attachment 620622 [details]
continuation of my just earlier attachment

Using Chrome we can browse the pages correctly.
I suspect the behavior is because of some virus
I am using Ubuntu 10.4 with the latest Mozilla Release 12.0

Rasheed
You need to log in before you can comment on or make changes to this bug.