[PP]Delete not working when News and POP reference same path

VERIFIED WORKSFORME

Status

defect
P3
normal
VERIFIED WORKSFORME
20 years ago
15 years ago

People

(Reporter: nbaca, Assigned: jefft)

Tracking

Trunk
x86
Linux
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Reporter

Description

20 years ago
Build 1999081608M9: Linux/Redhat 6.0

Overview: Problems occur when the prefs.js file lists the News server first
followed by a POP server where both reference the same directory structure:

1. Can't delete messages
2. Moving messages actually makes a copy of the message

Steps to Reproduce:

1. Create a prefs file where the News account is listed first (server1) and the
POP3 account is listed second (server2). They should also share a similar
directory structure (i.e. /u/acme/tester1) because they are using the same
test account. In the following prefs.js example the News and POP3 accounts are
both using the u/acme/tester1 directory structure.

// Mozilla User Preferences
// This is a generated file!

user_pref("browser.startup.homepage_override", false);
user_pref("mail.account.account1.identities", "id1");
user_pref("mail.account.account1.server", "server1");
user_pref("mail.account.account2.identities", "id2");
user_pref("mail.account.account2.server", "server2");
user_pref("mail.accountmanager.accounts", "account1,account2");
user_pref("mail.identity.id1.fullName", "tester1");
user_pref("mail.identity.id1.organization", "Company Inc.");
user_pref("mail.identity.id1.smtp_name", "tester1");
user_pref("mail.identity.id1.smtp_server", "smtpserver1");
user_pref("mail.identity.id1.useremail", "tester1@company.com");
user_pref("mail.server.server1.directory", "/u/acme/tester1");
user_pref("mail.server.server1.hostname", "news.mozilla.org");
user_pref("mail.server.server1.newsrc.file",
"/u/acme/tester1/.newsrc-news.mozilla.org");
user_pref("mail.server.server1.type", "nntp");
user_pref("nglayout.compatibility.mode", 1);
user_pref("mail.server.server2.directory", "/u/acme/tester1/nsmail");
user_pref("mail.server.server2.hostname", "popserver1");
user_pref("mail.server.server2.max_cached_connections", 5);
user_pref("mail.server.server2.password", "xxxxxx");
user_pref("mail.server.server2.type", "pop3");
user_pref("mail.server.server2.userName", "tester1");

2. Launch Mail
3. Select any folder with messages
4. Make a note of how many messages are in the folder
5. Select a message
6. Select the delete button.
7. Try moving a message to another folder.

Actual Results:
- The message is not deleted and the folder count remains the same.
- The message you tried to move actually makes a copy into the destination
folder and the folder counts reflect this.
Expected Results:
- I expected the message to be deleted and the folder counts to reflect the
change.
- The message should have been removed from the first folder and appeared only
in the second folder (destination folder). Also have message counts reflect the
change.

Additional Platforms/Versions:
- Win32/NT4 build 1999081608M9 works as expected.
- Mac 8.5.1 build 1999081608M9 works as expected.

Additional Information:
1. Didn't make a difference
- Tried using the Edit/Delete Message option.
- Tried another account (tester2) for News and POP.

2. Made a difference
- Reversed the order so that the POP account is first (server1) and the News
account is second (server2) and then it deletes as expected.
- Created a pref that points to one account (tester1) for News and another
account (tester2) for POP and then it deletes as expected.
Reporter

Updated

20 years ago
QA Contact: lchiang → nbaca
Reporter

Comment 1

20 years ago
Setting QA Assign to nbaca, adding lchiang to Cc: list.

Updated

20 years ago
Assignee: phil → jefft
Assignee

Updated

20 years ago
Status: NEW → ASSIGNED
Target Milestone: M11
Assignee

Comment 2

20 years ago
Interesting ... M11 ...

Updated

20 years ago
Status: ASSIGNED → RESOLVED
Closed: 20 years ago
Resolution: --- → WONTFIX

Comment 3

20 years ago
Account Wizard will not let you reference the same path. User plays with prefs
file at their own risk.
Reporter

Updated

20 years ago
Status: RESOLVED → REOPENED
Reporter

Comment 4

20 years ago
I think this bug should be reopened because problems can occur by using the
Account Wizard, without editing the prefs manually. Those problems being unable
to delete mail messages and moving a message actually performs a copy.

Steps to reproduce:
1. Using the Account Wizard, create a News account first
(i.e. Profile Name: "NewsFirst")
2. Using the Account Wizard again, add a mail account
3. Look at the prefs.js and notice that they share a similar directory path,
"C:\\32NT4\\Users50\\NewsFirst":

a. News: user_pref("mail.server.server1.directory",
"C:\\32NT4\\Users50\\NewsFirst\\News\\server1");

b. Mail: user_pref("mail.server.server2.directory",
"C:\\32NT4\Users50\\NewsFirst\\Mail\\server2");
Reporter

Updated

20 years ago
Resolution: WONTFIX → ---

Updated

20 years ago
Blocks: 11091

Comment 5

20 years ago
(target milestone is M11 or M12 - add to mail beta tracking bug)
Assignee

Updated

20 years ago
Status: REOPENED → ASSIGNED
Target Milestone: M11 → M13
Assignee

Comment 6

20 years ago
M13....

Comment 7

20 years ago
I don't understand why this is a bug. In Ninoschka's example, the news and mail
accounts generated different paths, right? So what's the problem?
Reporter

Comment 8

20 years ago
Build 1999121612M12: Linux

I tried to duplicate the problem but it no longer occurs. I created a news
account using the qatest20 identity and then added a mail account for qatest20.
I was able to delete and move messages as expected.
Assignee

Updated

20 years ago
Status: ASSIGNED → RESOLVED
Closed: 20 years ago20 years ago
Resolution: --- → WORKSFORME
Assignee

Comment 9

20 years ago
This is no longer a problem. Looks like it is fixed by itself.
Reporter

Updated

20 years ago
Status: RESOLVED → VERIFIED
Reporter

Comment 10

20 years ago
Verified Worksforme.
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.