[Calendar]The PM is overlapped with triangle icon in "Add Event" view.

RESOLVED WONTFIX

Status

RESOLVED WONTFIX
3 years ago
11 months ago

People

(Reporter: yulan.zhu, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:2.6?, b2g-v2.5 affected, b2g-master affected)

Details

(Whiteboard: LocRun2.5, ux-tracking)

Attachments

(2 attachments)

(Reporter)

Description

3 years ago
Created attachment 8688365 [details]
Czech_PM.png

[1.Description]:
[AriesKK&FlameKK v2.5][Calendar]Set time format as "12-hour" and enter "Add Event" view in Calendar, the PM is overlapped with triangle icon on the value selector button of time.
See attachment:Czech_PM.png

[2.Testing Steps]: 
Precondition: Set time format as "12-hour" and set your phone language as Czech.
1.Launch Calendar.
2.Tap "+" button to enter the "Add Event" view.

[3.Expected Result]: 
2.The PM should not be overlapped with triangle icon on the value selector button of time.

[4.Actual Result]: 
2.The PM is overlapped with triangle icon on the value selector button of time.

[5.Reproduction build]: 
Device: AriesKK v2.5 build (Affected):
Build ID               20151116174534
Gaia Revision          9473dbcbebf4e758a3b73200968efc69071b4312
Gaia Date              2015-11-16 15:49:25
Gecko Revision         http://hg.mozilla.org/releases/mozilla-b2g44_v2_5/rev/17877d161e5f62726027ee70101a7004dcad5a69
Gecko Version          44.0a2
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20151116.165317
Firmware Date          Mon Nov 16 16:53:25 UTC 2015
Bootloader             s1

Device: FlameKK 512mb v2.5  build (Affected)
Build ID               20151116173604
Gaia Revision          9473dbcbebf4e758a3b73200968efc69071b4312
Gaia Date              2015-11-16 15:49:25
Gecko Revision         http://hg.mozilla.org/releases/mozilla-b2g44_v2_5/rev/17877d161e5f62726027ee70101a7004dcad5a69
Gecko Version          44.0a2
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20151116.164743
Firmware Date          Mon Nov 16 16:47:52 UTC 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

[6.Reproduction Frequency]: 
Always Recurrence,10/10

[7.TCID]: 
16830

[8.Note]
1.Set language as Czech,  set time format as "12-hour" on v2.2 build, the PM cannot be shown.
2.The bottom of PM will be cut off on FlameKK v2.5.
(Reporter)

Updated

3 years ago
QA Whiteboard: [MGSEI-l10n-2F]
status-b2g-v2.5: --- → affected
Lancy: is this happening only in Czech locale? Or in other locales? Please move to Mozilla Localizations > Czech if this is the case.
Flags: needinfo?(yulan.zhu)
(Reporter)

Comment 2

3 years ago
Created attachment 8690701 [details]
All affected languages_v2.5&master.png

Hi delphine,
This issue also exists in Serbian Cyrillic, Urdu, Slovak and Bosnian languages.
On AriesKK v2.5&master build, the PM is overlapped with triangle icon in Serbian Cyrillic, Urdu and Bosnian languages, the bottom of PM will be cut off in Slovak language.
On Flame v2.5&master build, the bottom of PM will be cut off in Serbian Cyrillic, Urdu, Slovak and Bosnian languages.

See attachment:All affected languages_v2.5&master.png.

Build info:
AriesKK v2.5 build ID:20151119161838
AriesKK master build ID:20151120061630
FlameKK v2.5 build ID:20151119161153
FlameKK master build ID:20151119224634
Flags: needinfo?(yulan.zhu) → needinfo?(lebedel.delphine)
(Reporter)

Updated

3 years ago
QA Whiteboard: [MGSEI-l10n-2F] → [MGSEI-l10n-2F][MGSEI-Triage+]
status-b2g-master: --- → affected
Thanks Lancy. This is bad enough that we would need some UX help on this. Thanks
blocking-b2g: --- → 2.6?
Flags: needinfo?(lebedel.delphine) → needinfo?(firefoxos-ux-bugzilla)
NI to Patryk for visual design help.

Thanks for pinging the UX team!
Flags: needinfo?(firefoxos-ux-bugzilla) → needinfo?(padamczyk)
Whiteboard: LocRun2.5 → LocRun2.5, ux-tracking
I am not sure we should localize AM & PM.
Rationale:

+ We should default to the clock used formally in a specific country, for instance if a user changes their locale from Canada to Poland, the clock should change from 12h to 24h by default, the country operates on 24h as should our phone. If the user wants a 12h clock then we use AM / PM since they should know what AM / PM means, as those terms are synonymous with a 12h clock. 

+ We don't localize AM/PM to english (its a latin term after all), we don't say "3 in the afternoon" so why are we using these casual translations in other languages. We should always stick with what is the "official" date / time formatting per local.

+ I know some countries have their own abbreviations for AM/PM like Greece so lets use those when we can in a 12h configuration. But if there isn't an official abbreviated version of AM/PM then we should just use AM/PM.

We may need to look at using a 24h clock by default in many places, its the international standard after all, but for now I would prioritize a 24h clock over 12h clock when possible.
Flags: needinfo?(padamczyk)

Comment 6

11 months ago
Firefox OS is not being worked on
Status: NEW → RESOLVED
Last Resolved: 11 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.