Closed Bug 1225549 Opened 6 years ago Closed 6 years ago

Users are not receiving notification when reaching data limit

Categories

(Firefox OS Graveyard :: Gaia::Cost Control, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(blocking-b2g:2.6+, firefox45 fixed, b2g-v2.5 unaffected, b2g-master verified)

VERIFIED FIXED
2.6 S2 - 12/4
blocking-b2g 2.6+
Tracking Status
firefox45 --- fixed
b2g-v2.5 --- unaffected
b2g-master --- verified

People

(Reporter: AdamA, Assigned: timhuang)

References

()

Details

(Keywords: regression, smoketest, Whiteboard: [2.6-Daily-Testing][Spark][fromAutomation])

Attachments

(2 files)

Attached file logcat
Description:
If the user sets a data limit and then uses that amount of data they will not recieve a notification. 

Repro Steps:
1) Update a Aries to 20151117125448
2) Open usage app
3) Set a data limit of 5 mb
4) Open browser and navigate to youtibe
5) Watch a video using cell data
6) pull down notification tray to see data limit

Actual:
User does not recive a notification when reaching data limit

Expected:
It is expected that the user receives a notification when readhing the data limit

Environmental Variables:
Device: Aries 2.6 [Full Flash]
Build ID: 20151117125448
Gaia: 9473dbcbebf4e758a3b73200968efc69071b4312
Gecko: f8b569906e4c257687664227f470e416872d5802
Gonk: a19052e4389c3ae2d8fc3e7a74a475401baacc56
Version: 45.0a1 (2.6)
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:45.0) Gecko/45.0 Firefox/45.0

Repro frequency: 10/10
Link to failed test case: https://moztrap.mozilla.org/manage/case/8938/
See attached: video clip(https://youtu.be/S2fVlHs-zH8), logcat
blocking-b2g: --- → 2.6?
FWIW, This might be a regression from bug 1209654. To the person performing the regression window, please check first the builds before and after bug 1209654 landed.
This issue DOES occur on Flame 2.6.

Environmental Variables:
Device: Flame 2.6 [Full Flash][512mb]
BuildID: 20151117030236
Gaia: 9473dbcbebf4e758a3b73200968efc69071b4312
Gecko: 898c2c656e4b156c323416ef0c859915f3fd2308
Gonk: 205ac4204bbbb2098a8046444acba551ba5dc75a
Version: 45.0a1 (2.6) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:45.0) Gecko/45.0 Firefox/45.0

Result:
User does not receive a notification when reaching data limit
---------------------------------------
This issue DOES NOT occur on Flame 2.5.

Environmental Variables:
Device: Flame 2.5 [Full Flash][512mb]
Build ID: 20151109004552
Gaia: cf646c52bb947af28329b0a100df91d1b1f2a907
Gecko: 4eafef5b80f8985c94c4a067f130d37513e1a581
Gonk: 205ac4204bbbb2098a8046444acba551ba5dc75a
Version: 44.0a2 (2.5)
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:44.0) Gecko/44.0 Firefox/44.0

Result:
user receives notification when data limit is reached.
QA Whiteboard: [QAnalyst-Triage?]
Smoketest blocker.
blocking-b2g: 2.6? → 2.6+
When I just turned off my data connection and turned on wifi at the same time I received the cost control notification.
QA Contact: jthomas
9473dbcbebf4e758a3b73200968efc69071b4312 is a 2.5 gaia pull.  We need to check to see if this is still valid once we get a proper build.

See build status in :
https://bugzilla.mozilla.org/show_bug.cgi?id=1224628
https://bugzilla.mozilla.org/show_bug.cgi?id=1225465
Flags: needinfo?(ktucker)
Keywords: qawanted
Looked at Jlorenzo's comment, I think he's right.  It's not a gaia regression.
Flags: needinfo?(ktucker)
Keywords: qawanted
I reverted the patch from bug 1209654 and made my own build.  The alert did appear again.
Having said that the data usage is incorrect and so reverting doesn't make sense in this case...

Tim, can you look at this bug please?  Your patch fixed the data measurement but broke the alert.
Flags: needinfo?(tihuang)
Thanks to inform me this bug, I will start to look it.
Flags: needinfo?(tihuang)
Based on comment 7.
Blocks: 1209654
( I should mention that I reverted in my own local repo and tested; not in the hg repo.  I usually do testing locally first to make sure I have the right repo and result we want. )
Oops, I had made a mistake. There is a data structure should be modified as well when changing the data type of the threshold of the data alarm. And I had missed this due to my neglect, I apology for this. This patch is going to fix this bug, and I had tested it by myself, which works fine for me.
Assignee: nobody → tihuang
Status: NEW → ASSIGNED
Attachment #8689294 - Flags: review?(ettseng)
Comment on attachment 8689294 [details] [diff] [review]
bug1225549_v1.patch

Review of attachment 8689294 [details] [diff] [review]:
-----------------------------------------------------------------

This mistake is really obscure to discover in the first place.
Let's add a test case to avoid this kind of error in the future (file a follow-up).
Attachment #8689294 - Flags: review?(ettseng) → review+
Bug 1226089 is opened for adding the test case.
Adam, could you please help me on verifying this patch?
Flags: needinfo?(aalldredge)
test_cost_control_data_alert_mobile.py is failing because of this issue. The automation report sent on nov 17 shows it.
Whiteboard: [2.6-Daily-Testing][Spark] → [2.6-Daily-Testing][Spark][fromAutomation]
(In reply to Johan Lorenzo [:jlorenzo] (QA) from comment #16)
> test_cost_control_data_alert_mobile.py is failing because of this issue. The
> automation report sent on nov 17 shows it.

Johan, thanks for providing this information.

Tim, so we already have an automation test case for Cost Control alert.
Please try to test your patch by Gaia UI tests on TreeHerder.
(And maybe we don't need to add test cases if they already cover this.)
The test file in comment 16 is located at:
gaia-ui-tests/gaiatest/tests/cost_control/test_cost_control_data_alert_mobile.py

And I see these test suites on TryChooser syntax page.
  gaia-unit-tests
  gaia-ui-test-functional
  gaia-ui-test-oop
  gaia-ui-test-unit

We need to find out which one test_cost_control_data_alert_mobile.py belongs to.
Keywords: checkin-needed
(In reply to Ethan Tseng [:ethan] from comment #18)
> The test file in comment 16 is located at:
> gaia-ui-tests/gaiatest/tests/cost_control/test_cost_control_data_alert_mobile.py
More precisely at: 
gaia-ui-tests/gaiatest/tests/*functional*/cost_control/test_cost_control_data_alert_mobile.py

> And I see these test suites on TryChooser syntax page.
Then, it should be gaia-ui-test-functional, but to my knowledge, we don't have on-device testing on try yet. So I don't think it's worth waiting on it.

The only way to know, now is to run the test locally on your device[1]. 

[1] https://developer.mozilla.org/en-US/Firefox_OS/Automated_testing/gaia-ui-tests/Gaia_UI_Tests_Run_Tests#Testing_on_Firefox_OS_devices
https://hg.mozilla.org/mozilla-central/rev/b5dca1e99e66
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → 2.6 S2 - 12/4
(In reply to Johan Lorenzo [:jlorenzo] (QA) from comment #19)
> Then, it should be gaia-ui-test-functional, but to my knowledge, we don't
> have on-device testing on try yet. So I don't think it's worth waiting on it.

Hi Johan,
Can you help to verify the test case in Gaia UI test pass after this patch is landed?
Flags: needinfo?(jlorenzo)
Test passing on:
Build ID               20151125125652
Gaia Revision          9eca89f04628c99226e0d18c15d5ae11b71af0cf
Gaia Date              2015-11-25 06:47:04
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/1835baed2a38429a3cc301d21778a113d3a9e7d8
Gecko Version          45.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20151125.121409
Firmware Date          Wed Nov 25 12:14:19 UTC 2015
Bootloader             s1
Status: RESOLVED → VERIFIED
Flags: needinfo?(jlorenzo)
Flags: needinfo?(aalldredge)
Thank you very much for the great work here.
Depends on: 1229322
I'm sorry, the verification I did in comment 23 wasn't complete. The latest smoketest report done on Flame still show the problem. It doesn't occur on aries, though. I filed bug 1229322 to track this flame-specific issue.
Comment on attachment 8689294 [details] [diff] [review]
bug1225549_v1.patch

NOTE: Please see https://wiki.mozilla.org/Release_Management/B2G_Landing to better understand the B2G approval process and landings.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Bug 1225549
User impact if declined: Users will not receive notifications when reaching data limit
Testing completed: Yes.
Risk to taking this patch (and alternatives if risky): None.
String or UUID changes made by this patch:
Attachment #8689294 - Flags: approval‑mozilla‑b2g44?
Attachment #8689294 - Flags: approval‑mozilla‑b2g44?
You need to log in before you can comment on or make changes to this bug.