Closed Bug 1225566 Opened 4 years ago Closed 4 years ago

Slow scrolling with keyboard on PRIV by BlackBerry

Categories

(Firefox for Android :: Toolbar, defect)

43 Branch
ARM
Android
defect
Not set

Tracking

()

RESOLVED FIXED
Firefox 45
Tracking Status
firefox43 --- fixed
firefox44 --- fixed
firefox45 --- fixed

People

(Reporter: lquinn, Assigned: andchen)

Details

(Keywords: mobile)

Attachments

(1 file, 1 obsolete file)

User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:42.0) Gecko/20100101 Firefox/42.0
Build ID: 20151029151421
Firefox for Android

Steps to reproduce:

1. Using Firefox on a PRIV by BlackBerry, load any Web page that allows scrolling. I tested with http://www.bbc.com/news.
2. Open the slider.
3. Scroll vertically using the touch-sensitive keyboard.


Actual results:

Scrolling is very slow.


Expected results:

It should be faster, more like Chrome 46.
use the provided deltas, scaled by the preferred list item height.
use the provided deltas, scaled by the preferred list item height.
Attachment #8688581 - Attachment is obsolete: true
Component: Untriaged → General
Keywords: mobile
OS: Unspecified → Android
Product: Firefox → Firefox for Android
Hardware: Unspecified → ARM
Version: 43 Branch → Firefox 43
Attachment #8688582 - Flags: review?(liuche)
Attachment #8688582 - Flags: review?(liuche) → review?(bugmail.mozilla)
Component: General → Graphics, Panning and Zooming
Comment on attachment 8688582 [details] [diff] [review]
For pointer scrolling, we need to match Android platform behavior, to

Review of attachment 8688582 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good, thanks!
Attachment #8688582 - Flags: review?(bugmail.mozilla) → review+
https://hg.mozilla.org/mozilla-central/rev/c3dcefaff798
Status: UNCONFIRMED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 45
Is it possible to target Firefox 43 or 44 for this? The fix should be low risk, and it's a significant issue for Firefox users on the PRIV by BlackBerry.

(Thanks for taking the fix!)
Comment on attachment 8688582 [details] [diff] [review]
For pointer scrolling, we need to match Android platform behavior, to

Approval Request Comment
[Feature/regressing bug #]: it's been this way for a long time, but only exposed recently on new devices (i.e. BlackBerry PRIV)
[User impact if declined]: scrolling Fennec on the PRIV is very slow
[Describe test coverage new/current, TreeHerder]: not really
[Risks and why]: very low risk; the change just updates the scroll amount per event for "pointer" input sources (which already isn't used on most devices). Touch interaction is not affected.
[String/UUID change made/needed]: none
Attachment #8688582 - Flags: approval-mozilla-beta?
Attachment #8688582 - Flags: approval-mozilla-aurora?
Do we have one of these to test with? 
Kevin mentioned some risk of regression for the asus transformer pad. 
To me this sounds like support for a new feature/device without much testing. I am not sure about uplifting the fixes for Blackberry to beta.   Kats, what do you think about trying aurora instead and aiming for 44 release?
Flags: needinfo?(bugmail.mozilla)
(In reply to Liz Henry (:lizzard) (needinfo? me) from comment #8)
> Do we have one of these to test with? 

I don't. I'm assuming Liam and Andy tested that the patch works on BlackBerry before they put it up, (and looking at the patch I can see why it would).

> Kevin mentioned some risk of regression for the asus transformer pad.

Technically there is some risk but I don't think it's particularly risky. If we can get somebody to verify it didn't regress on the transformer that would be good.

> To me this sounds like support for a new feature/device without much
> testing. I am not sure about uplifting the fixes for Blackberry to beta.  
> Kats, what do you think about trying aurora instead and aiming for 44
> release?

I'm happy uplifting to aurora now and reconsidering beta if we can get somebody to verify on the transformer. I feel like it would be nice to support the device because if we have users migrating from other Android devices to the blackberry they will have a degraded experience and so we might lose them to Chrome or something. It's your call though.
Flags: needinfo?(bugmail.mozilla)
Margaret, what do you think? It would be nice to support this new device. HOw fast do you think it's reasonable to go here?
Flags: needinfo?(margaret.leibovic)
Liam, would you be able to verify that this issue is fixed as expected on the latest Nightly build (11/19)? Thanks!
Flags: needinfo?(lquinn)
(In reply to Liz Henry (:lizzard) (needinfo? me) from comment #10)
> Margaret, what do you think? It would be nice to support this new device.
> HOw fast do you think it's reasonable to go here?

This looks like a pretty simple patch. As long as this doesn't regress other devices, I think it's fine to uplift it to beta.
Flags: needinfo?(margaret.leibovic)
I tested the latest nightly (2015-11-20) on PRIV by BlackBerry, and it's working great. The scrolling feels much improved from Firefox Beta 43.0b4.
Flags: needinfo?(lquinn)
(In reply to Liam Quinn from comment #13)
> I tested the latest nightly (2015-11-20) on PRIV by BlackBerry, and it's
> working great. The scrolling feels much improved from Firefox Beta 43.0b4.

Thanks for a such a prompt follow up! This is highly appreciated.
Ioana, would you be able to do some manual testing on this patch (on latest Nightly build) on our most commonly tested/supported Fennec devices to address Margaret's concern in comment 12? Thanks!
Flags: needinfo?(chiorean.ioana)
Comment on attachment 8688582 [details] [diff] [review]
For pointer scrolling, we need to match Android platform behavior, to

Sounds good, let's fix this for aurora and beta, and count on next week to uncover possible (even if unlikely) regressions.
Attachment #8688582 - Flags: approval-mozilla-beta?
Attachment #8688582 - Flags: approval-mozilla-beta+
Attachment #8688582 - Flags: approval-mozilla-aurora?
Attachment #8688582 - Flags: approval-mozilla-aurora+
(In reply to Ritu Kothari (:ritu) from comment #15)
> Ioana, would you be able to do some manual testing on this patch (on latest
> Nightly build) on our most commonly tested/supported Fennec devices to
> address Margaret's concern in comment 12? Thanks!

Yes! We will cover this.
Flags: needinfo?(ioana.chiorean)
Flags: needinfo?(chiorean.ioana)
I doubt that testing will reveal anything interesting unless we have something with a secondary touch input. My concern is devices such as the Asus Transformer attachment and older Android devices with scroll-balls or touchpads.
Ritu, I just realized that we actually have no Blackberry with Android in the office. I can try to find a contributor or a friend with one to help out if there is none in the office either.
Flags: needinfo?(ioana.chiorean)
You need to log in before you can comment on or make changes to this bug.