Closed Bug 1225925 Opened 7 years ago Closed 5 years ago

[e10s] Debugger doesn't properly stop chrome scripts on about:newtab

Categories

(DevTools :: General, defect)

defect
Not set
critical

Tracking

(firefox44 affected, firefox45 affected)

RESOLVED WORKSFORME
Tracking Status
firefox44 --- affected
firefox45 --- affected

People

(Reporter: arni2033, Unassigned)

References

(Blocks 1 open bug)

Details

>>> My Info:   Win7_64, Nightly 45, 32bit, ID 20151116030208, new profile <<<
STR:
1. Open new tab page (about:newtab)
2. Open Inspector, click (ev) button near <html> node
3. In the opened event listeners tooltip, click "pause in debugger" button near event 'click'
4. Set breakpoint at the 1st line of event handler. Currently it's line 500: "switch (aEvent.type) {"
5. Click on any tile on the new tab page
6. Wait until the page will load, then click Inspector tab

Result:       
 Nightly consumes more and more RAM and the browser hangs

Expectations: 
 Debugger should stop chrome scripts - that'd solve this issue. Feel free to edit the summary
Has STR: --- → yes
The behavior was changed by bug 1200798:
When I wrote comment 0, Debugger always stopped script at Step 5. Now Debugger doesn't stop the script, and just collapses. So it seems that it just ignores the breakpoint and runs into bug 1068400

So, technically, this bug doesn't happen anymore. I don't know if the current behavior is correct, but I'll check comment 0 anyway once 1068400 is fixed.
I can't reproduce this bug anymore now. Tested in Nightly 55.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → WORKSFORME
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.