Closed Bug 1226032 Opened 7 years ago Closed 5 years ago

Implement _NET_WM_BYPASS_COMPOSITOR to automatically enable or disable the unredirect mode of the compositor

Categories

(Core :: Graphics: Layers, defect, P5)

55 Branch
All
Linux
defect

Tracking

()

RESOLVED DUPLICATE of bug 1134077

People

(Reporter: jeremy9856, Unassigned)

Details

(Keywords: feature, Whiteboard: gfx-noted)

User Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/46.0.2490.86 Safari/537.36

Steps to reproduce:

Hello,

I'm on Fedora 22 (Gnome Shell 3.16) with Nouveau drivers and I have tearing with the flash videos in Fullscreen when the compositor detect the fullscreen window and enable the unredirect mode.

Like I said here (https://bugzilla.mozilla.org/show_bug.cgi?id=1134077) I don't have tearing with others videos types like html5 videos.

So is it possible to implement the possibility to automatically enable or disable the unredirect mode of the compositor in fullscreen with this freedesktop.org feature ?

http://cgit.freedesktop.org/xdg/xdg-specs/tree/wm-spec/wm-spec.xml#n1579

We should be able to active it only for flash (plugin-container I think) or for everything. 

In addition it will be great if we can fix the tearing in Fullscreen for flash videos even when the unredirect mode is enabled.

Thank you.
OS: Unspecified → Linux
Hardware: Unspecified → All
Component: Untriaged → Plug-ins
Product: Firefox → Core
I opened an other bug report about Flash video tearing (https://bugzilla.mozilla.org/show_bug.cgi?id=1235282)

I disagree that this is triaged as a Plug-ins thing. I talked about Flash because it's where I have tearing but the _NET_WM_BYPASS_COMPOSITOR hint I suggest is not about Flash but it's a way for an app to control the system compositor.
Component: Plug-ins → Audio/Video: Playback
Version: 42 Branch → unspecified
It's not a playback issue per se. There's nothing we in the Media Team can do.

If you don't think it's specific to flash (test case would be good!) Maybe try graphics for compositor feature request, or submit a patch.
Component: Audio/Video: Playback → Graphics: Layers
Whiteboard: gfx-noted
So no interest in this ?
(In reply to jeremy9856 from comment #3)
> So no interest in this ?

This would be related to cleaning up our vsync handling in general on our GTK backend, which right now is somewhat of a big mess. It's not something we could get to in the short-term, but could be something that happens eventually - i.e. things like using the Present extension to ensure we do take advantange of any tear-free capabilities the X server is willing to provide us with... and as to what extent this WM property would interact with that. Maybe this summer we can take a look at it.
> Maybe this summer we can take a look at it.

That's very great ! It's not urgent but it will be a nice improvement, notably for tearing. By the way can you look at this bug please (Flash video tearing) https://bugzilla.mozilla.org/show_bug.cgi?id=1235282 ? Keep in mind that this property should be configurable with something like that :

No bypass : _NET_WM_BYPASS_COMPOSITOR=0
Compositing always enabled : _NET_WM_BYPASS_COMPOSITOR=2
Compositing enabled for Flash video in Fullscreen : _NET_WM_BYPASS_COMPOSITOR=2 if Flash in Fullscreen
Compositing always disabled : _NET_WM_BYPASS_COMPOSITOR=1
Compositing disabled only in Fullscreen : _NET_WM_BYPASS_COMPOSITOR=1 if in Fullscreen
...

Thanks !
(In reply to Lee Salzman [:lsalzman] from comment #4)
> Maybe this summer we can take a look at it.

Summer is almost here. Do you think that can be implemented now ?
Still not ?
Hello,

Is it possible to make it happen please ?
The gfx team has been very busy with other issues of late so we've not had time to look into it.
Keywords: feature
Priority: -- → P5
Version: unspecified → 49 Branch
I hope you will find time to implement it.
Hello,

It seem to be a fairly simple thing to add.

https://github.com/mpv-player/mpv/commit/ad3f75cc94adac9781fda93cc2a7c0c23ac0a606
https://github.com/mpv-player/mpv/commit/55846641eac86d55817be20eab00b8256a7e1c9a

Can you add this to Firefox now please ?

Thanks !
@jeremy9856: If you want some feature / bug fixed, either provide a patch, or (if you cannot) consider paying someone to write that patch for you, but please stop spamming bug reports with comments which add no useful information whatsoever and could be seen as just whining. Thanks.
(In reply to Lee Salzman [:lsalzman] from comment #9)
> The gfx team has been very busy with other issues of late so we've not had
> time to look into it.

Do you have the time now ?
(In reply to Lee Salzman [:lsalzman] from comment #4)
Maybe this summer we can take a look at it.

Well, the next year summer is almost finished and it still not implemented.
I hope it will be soon :)
Thanks !
Version: 49 Branch → 55 Branch
Even Google Chrome implement it now...

https://bugs.chromium.org/p/chromium/issues/detail?id=344141#c48
Duplicate of https://bugzilla.mozilla.org/show_bug.cgi?id=1134077, for which a patch is forthcoming.

The tearing issues with plugin-container windows will probably necessitate a separate fix, discussion should continue in https://bugzilla.mozilla.org/show_bug.cgi?id=1235282.
Status: UNCONFIRMED → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1134077
You need to log in before you can comment on or make changes to this bug.