Closed Bug 1226434 Opened 4 years ago Closed Last year

A content process should run while it has active service workers

Categories

(Core :: DOM: Service Workers, defect, P2)

defect

Tracking

()

RESOLVED DUPLICATE of bug 1438945
Tracking Status
firefox45 --- affected

People

(Reporter: catalinb, Unassigned)

References

(Blocks 1 open bug)

Details

(Whiteboard: SW-MUST)

Regardless if we decide to use a dedicated process or not, we need a mechanism that prevents a content process from shutting down while it has running service workers.

The immediate benefit would be that we can support push notifications on e10s when there are not content processes running.

The solution I have in mind for this is to add an ipc protocol for ServiceWorkerPrivate that's managed by PContent. PContent will keep the process running as long as there are service worker actors, the same way it works for managed pbrowsers.
Can we just use PBackground instead of a new PContent main thread protocol?
Priority: -- → P5
Whiteboard: SW-MUST
Priority: P5 → P2
QA Whiteboard: SW-MUST
This mechanism is implemented by SharedWorker remoting in bug 1438945.
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → DUPLICATE
Duplicate of bug: 1438945
You need to log in before you can comment on or make changes to this bug.