Closed Bug 1226573 Opened 7 years ago Closed 7 years ago

[Simulator][App deck] can't move to the first row of apps.

Categories

(Firefox OS Graveyard :: Gaia::TV, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: jj.evelyn, Assigned: jj.evelyn)

References

Details

Attachments

(1 file, 1 obsolete file)

On 720p screen size, when the user is navigating in app list of App deck, if there are many apps listed more than one row, move to the next row will make you can't go back to the previous row. Focus will jump to promotion list.
Assignee: nobody → ehung
Comment on attachment 8690069 [details] [review]
[gaia] evelynhung:issue-1226573 > mozilla-b2g:master

Rex, as you know the root cause is the spatial navigator library won't move to hidden element and will consider the closest element although they are visually in different area. 
In my patch, it's more like a workaround before migrating to the newer version of library. I remove promotion list from SpatialNavigator's calculating area, and deal with focus movement manually when the user intent is moving between different area.
Attachment #8690069 - Flags: review?(rexboy)
No longer depends on: 1225735
Comment on attachment 8690069 [details] [review]
[gaia] evelynhung:issue-1226573 > mozilla-b2g:master

r=me
Attachment #8690069 - Flags: review?(rexboy) → review+
merged into master
https://github.com/mozilla-b2g/gaia/commit/ab4c01c2799ab10d41bd937426a4e93907b44304
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
backout my patch because of having JavaScript error.
https://github.com/mozilla-b2g/gaia/commit/98e460ceef4b84752e3a5dac89e3507d593666e4
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Comment on attachment 8690764 [details] [review]
[gaia] evelynhung:issue-1226573 > mozilla-b2g:master

carry r+ since it's just a minor fix.
Attachment #8690764 - Flags: review+
Comment on attachment 8690069 [details] [review]
[gaia] evelynhung:issue-1226573 > mozilla-b2g:master

>https://github.com/mozilla-b2g/gaia/pull/33297
Attachment #8690069 - Attachment is obsolete: true
reland to master:
https://github.com/mozilla-b2g/gaia/commit/bb47091c609ba4d71634be684d93133361862819
Status: REOPENED → RESOLVED
Closed: 7 years ago7 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.