Closed Bug 122671 Opened 20 years ago Closed 19 years ago

Event dialog should not be modal

Categories

(Calendar :: General, defect)

x86
Linux
defect
Not set
normal

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: flacco002, Assigned: mikeypotter)

References

Details

When the event dialog is open, you're unable to do anything else in 
Mozilla - type into a message, browse, etc - until you close the event 
dialog.  Can this be made non-modal?  I see this being a BIG-TIME 
problem for a lot of people.
What exactly is the problem?
The problem is not that the calendar dialog is modal, the problem is that the
other "applications" of Mozilla don't ignore that modal dialog.
Do you agree?
I have installed the latest Calendar .xpi and I do not see this behavior on
Win32 (Win98SE, and Win2K).  Perhaps this is related to the problem with modal
Mozilla dialog's and Linux?  See bug # 65521 for more information.  Note that
#65521 is ~1 year old so I do not know if it is still a problem.  It is not
marked FIXED, though.
Yup, they look like the same bug to me... I'm adding 65521 as a blocker to this bug.
Status: UNCONFIRMED → NEW
Depends on: 65521
Ever confirmed: true
For now I'm disabling the modality of this window in the calendar.
Its in CVS now, should be in the next XPI I build, probaby tomorrow or Thursday.
Status: NEW → RESOLVED
Closed: 19 years ago
Resolution: --- → FIXED
verified
Status: RESOLVED → VERIFIED
The bugspam monkeys have been set free and are feeding on Calendar :: General. Be afraid for your sanity!
QA Contact: colint → general
You need to log in before you can comment on or make changes to this bug.