previous tabs doesn't restore properly if firefox was cleared from memory

RESOLVED DUPLICATE of bug 1044556

Status

()

defect
--
major
RESOLVED DUPLICATE of bug 1044556
4 years ago
2 years ago

People

(Reporter: tjtncks, Unassigned)

Tracking

({dataloss})

42 Branch
ARM
Android
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Reporter

Description

4 years ago
User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:42.0) Gecko/20100101 Firefox/42.0
Build ID: 20151029151421

Steps to reproduce:

1. surf in a tab around a lot of pages without close it.(I don't know how many is needed)
2. do something else until firefox process cleared from memory (or kill firefox manually.)
3. start firefox again.


Actual results:

some old page I visited in that tab appears when the firefox restarted.


Expected results:

It should show the page that I was looking at the time I last saw it
Reporter

Updated

4 years ago
OS: Unspecified → Android
Hardware: Unspecified → ARM
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:45.0) Gecko/20100101 Firefox/45.0
Build ID: 20151122030230

I could not reproduce the issue as described above.
Reporter, could you please try to reproduce this issue by using Firefox with a new profile?
https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles

Also, please specify what is the Operating system you are seeing this problem? (not clear if is on Windows 10 or Android)

Comment 2

4 years ago
I am not clear. Did you search in the History tab[1] in Firefox for Android? 

[1] https://support.mozilla.org/en-US/kb/use-awesome-screen-search-web-bookmarks-and-more

Comment 3

4 years ago
str
Making the report a little bit clear so that everyone can understand it,

Steps to reproduce:

1. surf in a tab around a lot of pages without close it.(I don't know how many is needed)
2. do something else until firefox process cleared from memory (or kill firefox manually.)
3. start firefox again.


Actual results:

Firefox starts with some random tabs that are in my history, but not the tabs that were opened while I closed firefox last time.


Expected results:

Firefox should start with the tabs and windows that were opened last time, not with random tabs from my history.


adding testday keyword on behalf of Ashickur Rahman
QA Whiteboard: [testday-20151127]

Updated

3 years ago
Severity: normal → major
Component: Untriaged → Data Providers
Keywords: dataloss
Product: Firefox → Firefox for Android
Version: 42 Branch → Firefox 42
This sound a bit like bug 1044556, except that one only happens when you're using multiple tabs.
I think it is safe to dupe this.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1044556
Reporter

Updated

2 years ago
Flags: needinfo?(tjtncks)
You need to log in before you can comment on or make changes to this bug.