SyntaxError: super is a reserved identifier

RESOLVED DUPLICATE of bug 1197932

Status

()

RESOLVED DUPLICATE of bug 1197932
3 years ago
3 years ago

People

(Reporter: elennaro, Unassigned)

Tracking

43 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:43.0) Gecko/20100101 Firefox/43.0
Build ID: 20151119130424

Steps to reproduce:

http://plnkr.co/edit/jrP2nZ0j6m2AND6hNVjM?p=preview


Actual results:

SyntaxError: super is a reserved identifier


Expected results:

alert('I'm walking'); should be shown
Same as bug 1226882. At the moment, classes are only supported on Nightly:
https://dxr.mozilla.org/mozilla-central/rev/3f5afaf4e6b72c4b1a20749b4ce7d945add5299f/js/src/jsversion.h#40
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Component: Untriaged → JavaScript Engine
Product: Firefox → Core
Resolution: --- → DUPLICATE
Duplicate of bug: 1197932
You need to log in before you can comment on or make changes to this bug.