If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Shaka Player throws "Player error" when trying to play MP4 ClearKey test stream

RESOLVED DUPLICATE of bug 1227720

Status

()

Core
Audio/Video: Playback
P2
normal
RESOLVED DUPLICATE of bug 1227720
2 years ago
2 years ago

People

(Reporter: cpeterson, Unassigned)

Tracking

(Blocks: 1 bug)

unspecified
Points:
---

Firefox Tracking Flags

(firefox45 affected)

Details

(Reporter)

Description

2 years ago
STR:
1. Load http://shaka-player-demo.appspot.com/
2. Select Test manifest: "Car/CENC" (YT DASH EME test) - MP4, ClearKey
3. Press the "Load stream" button.

RESULT:
The video does not load. The following errors are logged to the console log:

shaka.media.EmeManager.prototype.chooseEncrypted_() eme_manager.js:428
(Async: promise callback) shaka.media.EmeManager.prototype.initialize() eme_manager.js:168
(Async: promise callback) shaka.player.Player.prototype.load() player.js:322
app.load_() app.js:764
app.loadDashStream() app.js:727
app.loadStream() app.js:685
onclick() shaka-player-demo.appspot.com:1

Player error error { target: null, isTrusted: false, detail: TypeError, eventPhase: 0, bubbles: true, cancelable: false, defaultPrevented: false, timeStamp: 1448183589883120, NONE: 0, CAPTURING_PHASE: 1, AT_TARGET: 2 } app.js:884:3
app.onPlayerError_() app.js:884
shaka.util.FakeEventTarget.prototype.recursiveDispatch_() fake_event_target.js:167
shaka.util.FakeEventTarget.prototype.dispatchEvent() fake_event_target.js:145
shaka.player.Player.prototype.load/<() player.js:353
(Async: promise callback) shaka.player.Player.prototype.load() player.js:322
app.load_() app.js:764
app.loadDashStream() app.js:727
app.loadStream() app.js:685
onclick() shaka-player-demo.appspot.com:1

Invalid URI. Load of media resource  failed.
Comment hidden (obsolete)
No longer blocks: 1222851
Priority: -- → P2
Blocks: 1015800
(Reporter)

Updated

2 years ago
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1227720
You need to log in before you can comment on or make changes to this bug.