Text flow not working properly.

RESOLVED DUPLICATE of bug 163110

Status

()

Core
Layout
P3
major
RESOLVED DUPLICATE of bug 163110
16 years ago
14 years ago

People

(Reporter: Brad P. Crochet, Assigned: Marc Attinasi)

Tracking

Trunk
Future
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [bae:20020206], URL)

Attachments

(4 attachments)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.0.2 (X11; Linux i686; U;) Gecko/20011224
BuildID:    0.9.7

Also in: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.7) Gecko/20020121

It seems that this page has images that are to be flowed around on the right.
The text gets put into smaller and smaller columns, until eventually it makes it
to 1 word per line, and the images are on the left.

Reproducible: Always
Steps to Reproduce:
1. Go to the page.
2. View it.

Actual Results:  Incorrect layout.

Expected Results:  Correct layout.

This happens in both Galeon and Mozilla.

Comment 1

16 years ago
I cannot dup this in win98 or on mac, using builds from 1 Feb 02, possibly a 
Linux only bug
(Reporter)

Comment 2

16 years ago
I have verified this on Build ID 2002020103 on Windows XP, and 2002012814 under
Linux. 

The layout does not get messed up until further down on the page.

Comment 3

16 years ago
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.8+) Gecko/20020131
I can "fix" the page by adding </li> at the end of all paragraphs that start
with <li>.

Mozilla seems to believe that all text within the <li> tab must have the right
margin of the start of the <li> tag.  Since there is not </li>, each <li>
extends to the next one.  If the next image comes before the next <li>, the
image's right margin is the previous left margin.  Things accumulate from there.

So the point here seems to be that <li> text does not flow around other objects
on the page.  This happens for left- as well as right-aligned objects.

Comment 4

16 years ago
I am working on reducing the page to a reasonable test case, but from I have 
seen so far the page is constructed very poorly. The LIs are crossing paragraph 
and table boudaries. I suspect that once I get it reduced it will most likely be 
just poor web design.

Comment 5

16 years ago
Created attachment 68137 [details]
minimal testcase

Make the browser ~500 pixels wide.  the stuff on the left does not flow around
the table.

Comment 6

16 years ago
Andrew, in your reduced test case, the text should not flow around the table, 
the list and table are two different frames. However, if you place the table 
within the LI, and include the required <ul>, it then becomes part of the list 
frame and the text will flow around it.

In regards to the reported web page, I am attaching two test cases. The first 
one contains the poorly coded page content and the second one contains modified 
HTML that fixes the issue.

Comment 7

16 years ago
Created attachment 68148 [details]
poorly coded web page

Comment 8

16 years ago
Created attachment 68149 [details]
modified web page to render correctly

Comment 9

16 years ago
I take back what I said in comment #6. Upon further testing, it seems that the 
LI is doing the framing/flow and not the UL. That is very strange. It looks like 
the LI is not allowed to split, causing the no-flow situation.

I am attaching yet another test case to further display the issue -- thanks 
Andrew!

Comment 10

16 years ago
Created attachment 68158 [details]
test case displaying the flow parameters

This test case has two examples. The first example, the table is outside of the
ul, yet the ul frame seems to flow the width of the page. The second example
has the table nested within the first li, and the li content is thus able to
flow around the table.

Comment 11

16 years ago
Setting to P3/major and putting into moz1.0. It seems that the LI is not 
splitting as it should
Severity: normal → major
Status: UNCONFIRMED → NEW
Ever confirmed: true
Priority: -- → P3
Whiteboard: [bae:20020206]
Target Milestone: --- → mozilla1.0
Moving to Moz1.1
Target Milestone: mozilla1.0 → mozilla1.1

Comment 13

16 years ago
Layout messed up if ul tags were omitted, having only li tags results in no
indent and bullets appearing where they shouldn't (-2em I think from the text)

I think this is a case of forgiving bad mark-up. 

Putting ul tags around the li blocks results in correct positioning (indent and
bullet position)

Comment 14

16 years ago
The issue is not the bullets/left margin, but rather the right margin.  See the
last testcase, which has proper <ul> tags.

Comment 15

14 years ago
retargeting
Target Milestone: mozilla1.1alpha → Future

*** This bug has been marked as a duplicate of 163110 ***
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.