Scrubber in video controls is wonky

VERIFIED FIXED in Firefox 45

Status

()

Firefox for Android
Audio/Video
VERIFIED FIXED
2 years ago
2 years ago

People

(Reporter: snorp, Assigned: kats)

Tracking

({regression, reproducible})

unspecified
Firefox 46
regression, reproducible
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox42 unaffected, firefox43 unaffected, firefox44 unaffected, firefox45+ verified, firefox46+ verified, fennec45+)

Details

Attachments

(2 attachments)

Created attachment 8691436 [details]
scrubber-problem.png

It has a box around it.
Assignee: nobody → mark.finkle

Updated

2 years ago
Blocks: 704229

Comment 1

2 years ago
Inbound regression window:
last good build: f23ae6d4207719a808b285f0eb0504145b37d709
first bad build: 474012a19e10b189cb6a4521346787fdb44f49e3

pushlog:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=f23ae6d4207719a808b285f0eb0504145b37d709&tochange=474012a19e10b189cb6a4521346787fdb44f49e3
status-firefox42: --- → unaffected
status-firefox43: --- → unaffected
status-firefox44: --- → unaffected
status-firefox45: --- → affected
Keywords: regression, reproducible

Updated

2 years ago
status-firefox46: --- → affected
Blocks: 1223928
tracking-fennec: --- → ?
tracking-firefox45: --- → ?
tracking-firefox46: --- → ?
I suppose I should look at this.
Assignee: mark.finkle → bugmail.mozilla
Summary: Scrubbed in video controls is wonky → Scrubber in video controls is wonky
Apparently the scrubber is a xul|thumb so my change at https://hg.mozilla.org/integration/mozilla-inbound/rev/b5d654090848#l2.105 made it pick up that styling, which gave it a background color. I'll change it back to xul|scrollbar xul|thumb so it doesn't affect non-scrollbar thumbs.
Created attachment 8706629 [details] [diff] [review]
Patch
Attachment #8706629 - Flags: review?(snorp)
Attachment #8706629 - Flags: review?(snorp) → review+
Digging into the log these are:

###!!! ASSERTION: Scroll area should be inside client rect: 'r.width >= 0', file /builds/slave/fx-team-and-api-11-d-000000000/build/src/layout/generic/nsGfxScrollFrame.cpp, line 5071
###!!! ASSERTION: Scroll area should be inside client rect: 'r.height >= 0', file /builds/slave/fx-team-and-api-11-d-000000000/build/src/layout/generic/nsGfxScrollFrame.cpp, line 5079
The assertions came from the other patch in the push (bug 1238239) so I'm relanding this.

Comment 10

2 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/23c3a6a25a54
Status: NEW → RESOLVED
Last Resolved: 2 years ago
status-firefox46: affected → fixed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 46

Updated

2 years ago
tracking-fennec: ? → 45+

Comment 11

2 years ago
Verified as fixed in 46.0a1 2016-01-15;
Device: Asus Zenpad 8 (Android 5.0.2).
status-firefox46: fixed → verified
Tracking for 45+ since this is a recent regression. 
kats would you like to request aurora uplift?
tracking-firefox45: ? → +
tracking-firefox46: ? → +
Flags: needinfo?(bugmail.mozilla)
Comment on attachment 8706629 [details] [diff] [review]
Patch

Approval Request Comment
[Feature/regressing bug #]: bug 1223928
[User impact if declined]: the scrubber used to navigate through a video timeline has a border around it, which shouldn't be there
[Describe test coverage new/current, TreeHerder]: tested locally
[Risks and why]: very low risk, it was an accidental change to the CSS that caused it
[String/UUID change made/needed]: none
Flags: needinfo?(bugmail.mozilla)
Attachment #8706629 - Flags: approval-mozilla-aurora?
Attachment #8706629 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+

Comment 14

2 years ago
bugherderuplift
https://hg.mozilla.org/releases/mozilla-aurora/rev/fdefd1d82a09
status-firefox45: affected → fixed
Component: General → Audio/Video
Verified as fixed on:
Device: Nexus 6 (Android 6.0)
Build: Firefox for Android 45.0a2 (2016-01-25)
status-firefox45: fixed → verified
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.