Closed Bug 1227768 Opened 4 years ago Closed 4 years ago

User will be returned to thread view when deleting last message in thread with text entered

Categories

(Firefox OS Graveyard :: Gaia::SMS, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(b2g-v2.2 affected, b2g-v2.5 affected, b2g-master affected)

RESOLVED DUPLICATE of bug 1148719
Tracking Status
b2g-v2.2 --- affected
b2g-v2.5 --- affected
b2g-master --- affected

People

(Reporter: AdamA, Unassigned)

References

()

Details

(Whiteboard: [2.6-Daily-Testing][Spark])

Attachments

(1 file)

Attached file logcat
Description:
if the user is in a message thread and enters text into the text entry feild and then deletes all of the messages in thread they will be returned to the thread view while there is a draft still in that thread created from the text in the text field.

Repro Steps:
1) Update a Aries to 20151124120434
2) Open messages
3) Open a thread that exists or send a message to create one
4) Enter text in the text field
5) Delete all messages in the thread
6) Observe user being brought to thread view

Actual:
the user is brought back to throead view while the thread exists with a draft in it

Expected:
It is expected that the user remains in the thread with the draft.

Environmental Variables:
Device: Aries 2.6 [Full Flash]
Build ID: 20151124120434
Gaia: e63c07af8cc636b9ffac2c20f9b8ad7e7fe2b977
Gecko: 45273bbed8efaface6f5ec56d984cb9faf4fbb6a
Gonk: a19052e4389c3ae2d8fc3e7a74a475401baacc56
Version: 45.0a1 (2.6)
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:45.0) Gecko/45.0 Firefox/45.0

Repro frequency: 10/10
See attached: video clip(https://youtu.be/Dvu3qmhRV8M), logcat
This issue DOES occur on Flame 2.6, Flame 2.5, and Flame 2.2.

Environmental Variables:
Device: Flame 2.6 [Full Flash][512mb]
BuildID: 20151124120818
Gaia: e63c07af8cc636b9ffac2c20f9b8ad7e7fe2b977
Gecko: 45273bbed8efaface6f5ec56d984cb9faf4fbb6a
Gonk: 205ac4204bbbb2098a8046444acba551ba5dc75a
Version: 45.0a1 (2.6) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:45.0) Gecko/45.0 Firefox/45.0

Device: Flame 2.5 [Full Flash][512mb]
BuildID: 20151124190915
Gaia: 7726bfd621d709fa2d179704a44aebc1c309c296
Gecko: 124375497b14260515e8d2af9c8507a9995b7a47
Gonk: 205ac4204bbbb2098a8046444acba551ba5dc75a
Version: 44.0a2 (2.5) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:44.0) Gecko/44.0 Firefox/44.0

Device: Flame 2.2 [Full Flash][512mb]
BuildID: 20151120032503
Gaia: 885647d92208fb67574ced44004ab2f29d23cb45
Gecko: 462d8e9208ea
Gonk: bd9cb3af2a0354577a6903917bc826489050b40d
Version: 37.0 (2.2) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

Result:
the user is brought back to throead view while the thread exists with a draft in it
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Thanks for reporting!

I believe it works as expected, hovewer we want to improve this in the future. See bug 1148719 comment 19 and bug 1148719 comment 20 for the UX input on this. 

Please, undupe if you think I'm wrong.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1148719
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
Hi Oleg,
I think, it is expected. As it's very rare that user will do these two action at same time, i.e user delete all the message and still in thread view to continue with draft. Are we sure that we want this in future as we have bug filed for this. (Which you pointed to).

Thanks
Flags: needinfo?(azasypkin)
(In reply to kumar rishav (:rishav_) from comment #3)
> Are we sure that we want this in future as we
> have bug filed for this. (Which you pointed to).

I think current behavior may be confusing or even annoying (depending on user behavior pattern), but anyway, we always revise and re-confirm such decisions with UX right before we want to start implementing it after a long period of time (that will be the case here) :)
Flags: needinfo?(azasypkin)
You need to log in before you can comment on or make changes to this bug.