[TV] The default highlight button on browser FTE is incorrect

VERIFIED FIXED

Status

P2
normal
VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: ashiue, Assigned: yifan)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:2.5+, b2g-v2.5 fixed, b2g-master fixed)

Details

(Whiteboard: [ft:conndevices][partner-cherry-pick], URL)

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
STR:
1. First time launch browser
2. Check the FTE highlight button

Expected result:
1. Should be "Sign in"

Actual result:
1. "Skip" button is highlighted


Build info:
Build ID               20151121125805
Gaia Revision          e63c07af8cc636b9ffac2c20f9b8ad7e7fe2b977
Gaia Date              2015-11-24 03:47:05
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/abbd213422a560f1180c4ec6e3bf4792c2ea81ba
Gecko Version          45.0a1
Device Name            hammerhead
Firmware(Release)      5.1
Firmware(Incremental)  eng.worker.20151121.121712
Firmware Date          Sat Nov 21 12:17:28 UTC 2015
Bootloader             HHZ12f
(Reporter)

Updated

3 years ago
QA Whiteboard: [COM=TV FTU]

Updated

3 years ago
Assignee: nobody → yliao
blocking-b2g: --- → 2.5+
Flags: needinfo?(yliao)
Priority: -- → P2
Whiteboard: [ft:conndevices][partner-cherry-pick]
Created attachment 8691853 [details] [review]
[gaia] begeeben:1227816_the_default_highlight > mozilla-b2g:master
(Assignee)

Comment 2

3 years ago
Comment on attachment 8691853 [details] [review]
[gaia] begeeben:1227816_the_default_highlight > mozilla-b2g:master

Default focus on the finish button in FTEWizard.
Flags: needinfo?(yliao)
Attachment #8691853 - Flags: review?(rexboy)
(Assignee)

Updated

3 years ago
Status: NEW → ASSIGNED
Comment on attachment 8691853 [details] [review]
[gaia] begeeben:1227816_the_default_highlight > mozilla-b2g:master

r=me
I found some bugs on ftewizard though. I'll open some additional bug to refactor it.
Attachment #8691853 - Flags: review?(rexboy) → review+
(Assignee)

Comment 4

3 years ago
Merged into master:
https://github.com/mozilla-b2g/gaia/commit/10798fe53a31cef72800780e960a671a33afe466
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
(Assignee)

Comment 5

3 years ago
Comment on attachment 8691853 [details] [review]
[gaia] begeeben:1227816_the_default_highlight > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): 1194108
[User impact] if declined: Bad user experience
[Testing completed]: https://treeherder.mozilla.org/#/jobs?repo=gaia&revision=6f3b1e44f1f6875598ce73ca538832ed9cb31d10
[Risk to taking this patch] (and alternatives if risky): none
[String changes made]: none
Attachment #8691853 - Flags: approval-gaia-v2.5?

Updated

3 years ago
status-b2g-v2.5: --- → affected
status-b2g-master: --- → fixed

Comment 6

3 years ago
Comment on attachment 8691853 [details] [review]
[gaia] begeeben:1227816_the_default_highlight > mozilla-b2g:master

Approve for TV FTU 2.5
Attachment #8691853 - Flags: approval-gaia-v2.5? → approval-gaia-v2.5+
has problems during uplift Tomcats-MacBook-Pro-2:gaia Tomcat$ git cherry-pick 6f3b1e44f1f6875598ce73ca538832ed9cb31d10
error: could not apply 6f3b1e4... Bug 1227816 - [TV] The default highlight button on browser FTE is incorrect
hint: after resolving the conflicts, mark the corrected paths
hint: with 'git add <paths>' or 'git rm <paths>'
hint: and commit the result with 'git commit'
Flags: needinfo?(yliao)
(Assignee)

Comment 8

3 years ago
This bug depends on bug 1220581 . The reason this uplift failed is because the uplift in bug 1220581 seems to be incorrect.
Depends on: 1220581
Flags: needinfo?(yliao) → needinfo?(cbook)
https://github.com/mozilla-b2g/gaia/commit/e05621cbfd92b3fb4e5aef86621c57cd68fb0414 for 2.5
status-b2g-v2.5: affected → fixed
Flags: needinfo?(cbook)

Comment 10

3 years ago
Verify this issue on the latest build.
Launch Browser at the first time and the "Sign in" button is highlighted.
[Build Info]
Environment: 2.6 Simulator
gaia:
https://github.com/mozilla-b2g/gaia/commit/d9faad5c0f14fcd42f920c9104f0638f46a48b2a
gecko:
https://hg.mozilla.org/mozilla-central/rev/789a12291942763bc1e3a89f97e0b82dc1c9d00b
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.