If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Marionette tests for audio channels compete each other

RESOLVED FIXED

Status

Firefox OS
Gaia::System::Audio Mgmt
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: evanxd, Assigned: evanxd)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

2 years ago
Content audio channel compete with Normal, Content, Alarm, System, Ringer, Telephony, Notification, and Public Notification audio channels.
(Assignee)

Comment 1

2 years ago
The expectations is defined in [1].
[1]: https://bug1096163.bmoattachments.org/attachment.cgi?id=8691714#12
(Assignee)

Updated

2 years ago
Summary: Content audio channel compete with all kinds of audio channels. → Content audio channel competes with all kinds of audio channels.
(Assignee)

Updated

2 years ago
Assignee: nobody → evan

Comment 2

2 years ago
Created attachment 8693949 [details] [review]
[gaia] evanxd:bug-1227825 > mozilla-b2g:master
(Assignee)

Comment 3

2 years ago
Comment on attachment 8693949 [details] [review]
[gaia] evanxd:bug-1227825 > mozilla-b2g:master

Hi Luke,

Could you review the patch?

Thanks.
Attachment #8693949 - Flags: review?(lchang)
(Assignee)

Updated

2 years ago
Blocks: 1227826
(Assignee)

Updated

2 years ago
Depends on: 1230074
(Assignee)

Updated

2 years ago
Summary: Content audio channel competes with all kinds of audio channels. → Content, alarm, system, ringer, telephony, notification, and public notification audio channels competes with all kinds of audio channels.
(Assignee)

Updated

2 years ago
Duplicate of this bug: 1227831
(Assignee)

Updated

2 years ago
Duplicate of this bug: 1227830
(Assignee)

Updated

2 years ago
Duplicate of this bug: 1227829
(Assignee)

Updated

2 years ago
Duplicate of this bug: 1227828
(Assignee)

Updated

2 years ago
Duplicate of this bug: 1227827
(Assignee)

Updated

2 years ago
Duplicate of this bug: 1227826
Comment on attachment 8693949 [details] [review]
[gaia] evanxd:bug-1227825 > mozilla-b2g:master

Everything Look good! Thanks.
Attachment #8693949 - Flags: review?(lchang) → review+
(Assignee)

Updated

2 years ago
Duplicate of this bug: 1227824
(Assignee)

Updated

2 years ago
Summary: Content, alarm, system, ringer, telephony, notification, and public notification audio channels competes with all kinds of audio channels. → Marionette tests for audio channels compete each other
(Assignee)

Updated

2 years ago
No longer depends on: 1230074
(Assignee)

Comment 12

2 years ago
We can land the code once the treeherder[1] is good.

[1]: https://treeherder.mozilla.org/#/jobs?repo=gaia&revision=ddffdd33c6c5036863f9a8d56674bd883f96aa03
(Assignee)

Comment 13

2 years ago
Thanks for the review, Luke.
(Assignee)

Comment 14

2 years ago
master: https://github.com/mozilla-b2g/gaia/commit/e0a7a4663429b71a5e2e91d96ac3b99a4609a7af
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.