Poor (thin and wiry) fonts in scrollable form text input

RESOLVED DUPLICATE of bug 1122916

Status

()

Core
Graphics: Layers
RESOLVED DUPLICATE of bug 1122916
2 years ago
2 years ago

People

(Reporter: Mark Straver, Unassigned)

Tracking

({regression})

Trunk
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
Created attachment 8691957 [details]
Example of thin and normal font of the same text

Related to bug 1227799 in that the type of font artifacts are the same.

When entering text in a form multiline input field that has scroll (like this description box on BMO), the font rendering becomes thin and wiry the moment the content is scrolled (by e.g. entering more text than the default space allows). If scrolling is stopped for a couple of seconds, the font rendering "snaps" back to a more legible, bolder version.

Regression window:
Last good revision: b0b3dcfa5557 (2015-07-24)
First bad revision: d3228c82badd (2015-07-25)
(Reporter)

Comment 1

2 years ago
I gather the culprit would be bug 1157745, i.e.: an issue with APZ on desktop.
[Tracking Requested - why for this release]: regression from APZ.
Blocks: 1178298
status-firefox45: --- → affected
tracking-firefox45: --- → ?
Markus, is this another instance of bug 1122916, on windows?
Flags: needinfo?(mstange)
(Reporter)

Comment 4

2 years ago
FTR: Switching off APZ completely fixes this issue.
Yes it is.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(mstange)
Resolution: --- → DUPLICATE
Duplicate of bug: 1122916
No longer blocks: 1178298
status-firefox45: affected → ---
tracking-firefox45: ? → ---
See Also: bug 1227799
You need to log in before you can comment on or make changes to this bug.