Last Comment Bug 122799 - [INLINE-H] line-breaking bug caused by +ve margin-right on inline elements [LINE] {ll}
: [INLINE-H] line-breaking bug caused by +ve margin-right on inline elements [L...
Status: RESOLVED WORKSFORME
[Hixie-P2][CSS1-5.5.2] (high profile:...
: css1, helpwanted, testcase
Product: Core
Classification: Components
Component: Layout: Block and Inline (show other bugs)
: Trunk
: All All
: P3 minor with 1 vote (vote)
: mozilla1.2alpha
Assigned To: layout.block-and-inline
: Hixie (not reading bugmail)
: Jet Villegas (:jet)
Mentors:
http://www.w3.org/Style/CSS/Test/curr...
: 400446 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2002-01-31 10:20 PST by Hixie (not reading bugmail)
Modified: 2010-10-14 12:04 PDT (History)
4 users (show)
dbaron: in‑testsuite?
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Hixie (not reading bugmail) 2002-01-31 10:20:22 PST
STEPS TO REPRODUCE
   1. Open http://www.w3.org/Style/CSS/Test/CSS1/20020115/test5505b.htm
   2. Resize your window until the dot after the first span of aqua is at the
      end of the line.
   3. Shrink the window slowly.

EXPECTED RESULTS
   The last word, the margin, and the dot should all jump to the next line just 
   as the dot would overflow the gray background.

ACTUAL RESULTS
   The dot overflows the gray box by a couple of pixels and then the entire span  
   jumps to the next line as if it had white-space: nowrap set.

   If you continue shrinking, the correct behaviour occurs (line break in the 
   span). If you continue shrinking until the dot is once again at the end of 
   the line, you can get both the dot and the end margin to overlap the end of 
   the gray container background.

Note: There are two bugs listed here (the sudden snap down of the entire line at
some specific widths, and the overlap of the dot). I would have filed the dot
overlap issue separately, but I couldn't work out what the expected behaviour
was for that.
Comment 1 Kevin McCluskey (gone) 2002-02-27 13:58:57 PST
Reassigning to Alex.
Comment 2 scottputterman 2002-03-04 19:17:21 PST
Moving Netscape owned 0.9.9 and 1.0 bugs that don't have an nsbeta1, nsbeta1+,
topembed, topembed+, Mozilla0.9.9+ or Mozilla1.0+ keyword.  Please send any
questions or feedback about this to adt@netscape.com.  You can search for
"Moving bugs not scheduled for a project" to quickly delete this bugmail.
Comment 3 David Baron :dbaron: ⌚️UTC-8 2002-06-11 13:15:27 PDT
See also bug 122795 and bug 46918.
Comment 4 Greg K. 2002-07-11 22:06:01 PDT
Reconfirmed using FizzillaCFM/2002070913. Setting All/All.
Comment 5 David Baron :dbaron: ⌚️UTC-8 2003-03-30 14:31:47 PST
->Layout: Block&Inline
Comment 6 David Baron :dbaron: ⌚️UTC-8 2003-03-30 14:32:02 PST
->Layout: Block&Inline
Comment 7 Jackie 2005-06-24 13:06:30 PDT
(In reply to comment #6)
> ->Layout: Block&Inline

Is this the same bug that causes the CSS2.1 margin-right test to fail? 

Test:
http://www.w3.org/Style/CSS/Test/CSS2.1/current/t0803-c5502-imrgn-r-00-b-ag.htm
Comment 8 Mats Palmgren (:mats) 2007-10-19 18:22:53 PDT
*** Bug 400446 has been marked as a duplicate of this bug. ***
Comment 9 Xbehave 2008-03-06 16:46:51 PST
http://www.w3.org/Style/CSS/Test/CSS2.1/current/t0803-c5502-imrgn-r-00-b-ag.htm WFM
and as far as i can tell so does the test of shrinking the browser
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9b5pre) Gecko/2008030604 Minefield/3.0b5pre)
Comment 10 David Baron :dbaron: ⌚️UTC-8 2008-11-23 07:34:29 PST
This works for me on trunk; probably fixed by roc's text frame rewrite or some of the many followup fixes in which he changed line breaking.
Comment 11 David Baron :dbaron: ⌚️UTC-8 2010-10-14 12:04:12 PDT
One case still exists; filed bug 604446.

Note You need to log in before you can comment on or make changes to this bug.