Closed Bug 1228151 Opened 4 years ago Closed 4 years ago

After finish editing pinned site 'clipboard manager' UI remains on Home screen

Categories

(Firefox OS Graveyard :: Gaia::System::Window Mgmt, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(b2g-v2.5 affected, b2g-master verified)

RESOLVED FIXED
2.6 S4 - 1/1
Tracking Status
b2g-v2.5 --- affected
b2g-master --- verified

People

(Reporter: MaxIvanov, Assigned: TYLin)

References

(Blocks 1 open bug, )

Details

(Whiteboard: [2.6-Daily-Testing][Spark][systemsfe])

Attachments

(3 files)

Description:
Clipboard manager UI remains on Home screen after users finish edit a pinned web site

Repro Steps:
1) Update a Aries to 20151125131311
2) Pin any web site to the Home screen
3) Start editing previously pinned site
4) Invoke clipboard manager
5) Tap on the 'select all' button
6) Close edit mode by tapping on the 'X' button
7) Observe Home screen

Actual:
Clipboard manager UI remains on the Home screen

Expected:
No clipboard manager UI on the Home screen

Environmental Variables:
Device: Aries 2.6
Build ID: 20151125131311
Gaia: 9eca89f04628c99226e0d18c15d5ae11b71af0cf
Gecko: 1835baed2a38429a3cc301d21778a113d3a9e7d8
Gonk: a19052e4389c3ae2d8fc3e7a74a475401baacc56
Version: 45.0a1 (2.6)
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:45.0) Gecko/45.0 Firefox/45.0

Repro frequency: (100 %)
See attached: (video clip, logcat)
This does occur on  Flame 2.6, Flame 2.5 and Aries 2.5
Clipboard manager UI remains on the Home screen
 
Device: Flame 2.6 (KK)(512mb)
Build ID: 20151125030226
Gaia: 37250b125e0db6966875d3b37b117f6d9b76cbc0
Gecko: 099f695d31326c39595264c34988a0f4b7cbc698
Gonk: 205ac4204bbbb2098a8046444acba551ba5dc75a
Version: 45.0a1 (2.6)
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:45.0) Gecko/45.0 Firefox/45.0

Device: Flame 2.5 (KK)(512mb)
Build ID: 20151125122518
Gaia: 93b8bf2de3258c25199d97036c50a87667059148
Gecko: 913818c231658f959ce779ce2763ddb864024057
Gonk: 205ac4204bbbb2098a8046444acba551ba5dc75a
Version: 44.0a2 (2.5)
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:44.0) Gecko/44.0 Firefox/44.0

Device: Aries 2.5
Build ID: 20151125120101
Gaia: 93b8bf2de3258c25199d97036c50a87667059148
Gecko: 913818c231658f959ce779ce2763ddb864024057
Gonk: a19052e4389c3ae2d8fc3e7a74a475401baacc56
Version: 44.0a2 (2.5)
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:44.0) Gecko/44.0 Firefox/44.0
---------------------------------------------------------------------

This does NOT occur on  Flame 2.2

Device: Flame 2.2
Build ID: 20151125032502
Gaia: 885647d92208fb67574ced44004ab2f29d23cb45
Gecko: 462d8e9208ea
Gonk: bd9cb3af2a0354577a6903917bc826489050b40d
Version: 37.0 (2.2)
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Whiteboard: [2.6-Daily-Testing][Spark]
Attached file logs.txt
Alison, can you take a look at this please?
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker) → needinfo?(ashiue)
Hi Gregor,

Could you please dispatch this text selection related issue to suitable person to check? Thank you.
Flags: needinfo?(ashiue) → needinfo?(anygregor)
Whiteboard: [2.6-Daily-Testing][Spark] → [2.6-Daily-Testing][Spark][systemsfe]
tlin, can you help out here?
Flags: needinfo?(anygregor) → needinfo?(tlin)
After a quick debug, the problem is more than it seems. We now have one text selection dialog (app_text_selection_dialog.js) per app. At the editing pinned site page, the dialog displayed is from the b2g process, but the blue carets on the page is from bookmark process. Somehow the bookmark process does not have its own dialog. Thus the copy and paste buttons is not functional as well. 

I am taking PTO soon, and unable to dig deeper in a few weeks. If any Gaia developer is interested in this bug, the possible direction is to figure out why the bookmark app does not have a app_text_selection_dialog.js.
Flags: needinfo?(tlin)
Attachment #8701744 - Flags: review?(timdream)
Attachment #8701744 - Flags: review?(timdream) → review+
Thank you for the review!
Assignee: nobody → tlin
Keywords: checkin-needed
https://github.com/mozilla-b2g/gaia/commit/8287b58d2a46cfbeaafe02bd37735eaf2149b7c1
Status: NEW → RESOLVED
Closed: 4 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → 2.6 S4 - 1/1
This bug has been verified as "pass" on the latest build of Flame master and Aries KK master by the STR in comment 0.

Actual results: After finish editing pinned site, 'clipboard manager' UI disappears and does not remain on Home screen.
See attachment: verified_Aries_master.3gp
Reproduce rate: 0/10


Device: Flame master_512mb (Pass)
Build ID               20151230150203
Gaia Revision          1899109c9fd9b9e2244155c4b9e966c0a48368fc
Gaia Date              2015-12-30 03:25:58
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/c690c50b2b543b420803e8192d6e08e06b20e0a3
Gecko Version          46.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20151230.185046
Firmware Date          Wed Dec 30 18:50:59 EST 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

Device: Aries KK master (Pass)
Build ID               20151230110019
Gaia Revision          1899109c9fd9b9e2244155c4b9e966c0a48368fc
Gaia Date              2015-12-30 03:25:58
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/c690c50b2b543b420803e8192d6e08e06b20e0a3
Gecko Version          46.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20151230.113103
Firmware Date          Wed Dec 30 11:31:11 UTC 2015
Bootloader             s1
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][MGSEI-Triage+]
You need to log in before you can comment on or make changes to this bug.