Closed Bug 1228179 Opened 4 years ago Closed 4 years ago

Reloading (F5) loads about:blank instead of current page

Categories

(Core :: DOM: Navigation, defect)

Unspecified
All
defect
Not set

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: alice0775, Unassigned)

References

Details

(Keywords: qawanted, regression, Whiteboard: [fixed by backout of bug 1175267])

+++ This bug was initially created as a clone of Bug #1213650 +++

Bug #1213650 did not fix the problem, nothing improved.

Buid Identifier:
https://hg.mozilla.org/mozilla-central/rev/099f695d31326c39595264c34988a0f4b7cbc698
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:45.0) Gecko/20100101 Firefox/45.0 ID:20151125030231

It is annoyance bug.

Reproducible: very often , after launch browser

Steps To Reproduce:
1. Copy a url https://bugzilla.mozilla.org/attachment.cgi?id=8672350 (or any other url) to clipboard
2. Start Nightly
3. Right click location bar and chose "Paste & Go"
   (Perform as early as possible after UI available)
4. Wait to load the page
5. Click Reload button

Actual Results:
Reloading (F5) loads about:blank instead of current page

Expected Results:
Reloading (F5) should load current page
This is not duplication of bug 1226657.
Regression window:
https://hg.mozilla.org/integration/fx-team/pushloghtml?fromchange=0bfe3ec74b6063d996cb400e5a9ead2689efb669&tochange=1f9d9bfafd51

Regressed by :
	9410aa231e87	Dave Townsend — Bug 1175267: When a load redirected to a new process is cancelled restore the existing content. r=billm
The offending Bug 1175267 should be simply backed out!
(In reply to Alice0775 White from comment #1)
> This is not duplication of bug 1226657.

Are you certain? How can you be sure?
Flags: needinfo?(alice0775)
(In reply to Mike Conley (:mconley) - Needinfo me! from comment #4)
> (In reply to Alice0775 White from comment #1)
> > This is not duplication of bug 1226657.
> 
> Are you certain? How can you be sure?

The problem appears again.
Because, you had landed the offending Bug 1175267 again.
Flags: needinfo?(alice0775)
Hey Alice0775,

Let me try to rehash what has happened here.

Bug 1213650 was originally filed by you. arni2033@yandex.ru then followed up in that bug reporting experiencing a similar thing.

I eventually posted a patch, and arni2033@yandex.ru reported that it made things improve in bug 1213650 comment 34 (in that it was harder for him to reproduce the issue). I accidentally gave you a link in bug 1213650 comment 41 to the backout build, which is why it fixed things for you.

So I landed the patches that made things better for arni2033@yandex.ru, and filed bug 1226657 for the rarer case that you were still hitting.

So that's why I'm confused about why this bug was filed, because I filed bug 1226657 to cover the case you were hitting.
Flags: needinfo?(mconley) → needinfo?(alice0775)
The problem is not rare case. It happens almost 100% when I try.

Before landing Bug 1175267, Never experienced this problem.
Flags: needinfo?(alice0775)
I guess this should be RESOLVED WORKSFORME when the backout of bug 1175267 hits central. Alice0775, can you please confirm when you have a build?
Flags: needinfo?(mconley) → needinfo?(alice0775)
(In reply to Mike Conley (:mconley) - Needinfo me! from comment #8)
> I guess this should be RESOLVED WORKSFORME when the backout of bug 1175267
> hits central. Alice0775, can you please confirm when you have a build?

I can confirm the problem is fixed on latest Nightly.

https://hg.mozilla.org/mozilla-central/rev/47b49b0d32360fab04b11ff9120970979c426911
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:45.0) Gecko/20100101 Firefox/45.0 ID:20151127030231
Status: NEW → RESOLVED
Closed: 4 years ago
tracking-e10s: ? → ---
Flags: needinfo?(alice0775)
Resolution: --- → WORKSFORME
Whiteboard: [fixed by backout of bug 1175267]
You need to log in before you can comment on or make changes to this bug.