Closed Bug 1228263 Opened 5 years ago Closed 1 year ago

One click search alias save issue

Categories

(Firefox :: Search, defect, P3)

defect

Tracking

()

RESOLVED WORKSFORME
Tracking Status
firefox45 --- affected
firefox70 --- unaffected

People

(Reporter: aflorinescu, Unassigned)

Details

(Whiteboard: fxsearch)

Steps:
1. Click on the magnifying glass from the Search toolbox and choose "Change Search Settings".
2. Remove half of the default search engines.
3. For one of the search engines left in the list click under the Keyword column in order to save an alias and input a text.
4. There are two ways of saving the alias text after input:
4.1 Press enter.
4.2 Focus away.


Actual Result:
On the 4.2 step if you focus away by clicking on an existing search engine, the save will be performed, but if you focus away by clicking on a space left by the removal of the search engines from the step 2, the save won't be performed. Same behavior when
editing an alias.
polish in preferences with focus finder not firing correctly
Priority: -- → P3
Whiteboard: fxsearch

Adrian, this seems to work fine for me on the latest nightly, please could you confirm?

Flags: needinfo?(aflorinescu)

I cannot reproduce either in Nightly v70.0a1 (2019-08-21) on Windows 10 or Ubuntu 18. Might have been fixed in the meantime. Thanks.

Status: NEW → RESOLVED
Closed: 1 year ago
Flags: needinfo?(aflorinescu)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.