Closed Bug 1228488 Opened 4 years ago Closed 4 years ago

Pass WEBLG2 gl-enum-test test

Categories

(Core :: Canvas: WebGL, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla45
Tracking Status
firefox45 --- fixed

People

(Reporter: mtseng, Assigned: mtseng)

References

()

Details

(Whiteboard: [gfx-noted])

Attachments

(1 file)

No description provided.
Comment on attachment 8692822 [details] [diff] [review]
Return INVALID_ENUM for GL_UNIFORM_NAME_LENGTH.

Review of attachment 8692822 [details] [diff] [review]:
-----------------------------------------------------------------

::: dom/canvas/WebGL2ContextUniforms.cpp
@@ +325,5 @@
>      if (IsContextLost())
>          return;
>  
> +    if (pname == LOCAL_GL_UNIFORM_NAME_LENGTH)
> +        return ErrorInvalidEnumInfo("getActiveUniforms: pname", pname);

Please write this out as:

if (...) {
    ErrorFoo(...);
    return;
}
Attachment #8692822 - Flags: review?(jgilbert) → review+
Duplicate of this bug: 1170872
https://hg.mozilla.org/mozilla-central/rev/3a5c79d93504
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla45
You need to log in before you can comment on or make changes to this bug.