Closed Bug 1228591 Opened 5 years ago Closed 4 years ago

After sending a copy link of the room to another PC, the person cannot join the conversation

Categories

(Hello (Loop) :: Client, defect, P3)

x86_64
Windows 7
defect

Tracking

(Not tracked)

RESOLVED INCOMPLETE

People

(Reporter: ithompson4, Unassigned)

References

()

Details

(Keywords: reproducible, testcase, Whiteboard: [testday-20151127])

Attachments

(2 files)

140.16 KB, image/png
Details
1.10 MB, application/vnd.openxmlformats-officedocument.wordprocessingml
Details
Attached image test11_2_Bug.png
User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:43.0) Gecko/20100101 Firefox/43.0
Build ID: 20151126120800

Steps to reproduce:

1. Launch Firefox Hello icon.
2. Start conversation and and link to another person.



Actual results:

After clicking the link the 2nd person cannot join the conversation.


Expected results:

After clicking the link the 2nd person should have been able to join the conversation
Severity: normal → major
QA Whiteboard: [testday-20151127]
OS: Unspecified → Windows 7
Priority: -- → P2
Hardware: Unspecified → x86_64
Whiteboard: [testday-20151127]
Component: Untriaged → Client
Product: Firefox → Hello (Loop)
Version: 43 Branch → unspecified
This works fine for me - I've been testing at various times today.

Please can you provide more information about what failed, the versions of Firefox, and what was seen on the web console.
Flags: needinfo?(ithompson4)
Priority: P2 → P3
The machines used both ran Firefox 43 beta 7 and Windows 7 64-bit. I logged in using a different profile on each machine, Gmail on one and my Seneca College profile on the other.

I tried this again today and it worked. On the 27th November Testday I had a Webcam + Microphone on the receiving machine, but a Microphone with no Webcam on the sending machine. This combination produced the error reported above

However I was able to dig up an old webcam today that I could use on the other machine. When both machines had webcam's and microphones it worked. Might be worth mentioning this for the future as a pre-condition for this test case as you don't need this for Skype. 

I did find another bug however as part of my re-test that I will post with regard to test case 25 - it does not save the history of an unsent message when closed and reopened by the sender. 

Please close this bug. I will log a new one concerning the unsaved message.
Flags: needinfo?(ithompson4)
Hello should be working with either end of the call without a web cam. Just a microphone should be sufficient. Please could you retest and keep an eye on the browser console for any relevant messages or errors.
Flags: needinfo?(ithompson4)
Tried again a couple of times today using the same machines as before. The first time was early evening. The second time was around 2am this morning Eastern Standard Time. The tests were the same:

1. Microphones and Webcam for the receiving machine, microphone only for the sending machine
2. Sharing Microphone only for both the sending and receiving machines.
3. Microphones and Webcam for both the sending and receiving machines.
 
During the evening all tests were successful except for the first test which experienced a technical issue after 2 minutes of the conversation. After reconnecting it worked and I left it open for 15 minutes before terminating the conversation. But when I retested at around 2am EST this morning all tests failed. I have attached screen shots of the failed tests.

I used the same machines and internet LAN connection on both occasions. The LAN connection was working fine both during the early evening and the early morning tests. There were no error messages produced for either combination 1 or 2 above when they failed. But Combination 3 produced a technical difficulties message on both machines during the early morning tests.
Flags: needinfo?(ithompson4)
Rank: 31
Mike is going to follow up on trying to reproduce this
Flags: needinfo?(mdeboer)
Flags: needinfo?(mdeboer)
Support for Hello/Loop has been discontinued.

https://support.mozilla.org/kb/hello-status

Hence closing the old bugs. Thank you for your support.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.