Note: There are a few cases of duplicates in user autocompletion which are being worked on.

Css box width miscalculated for preformatted text, which overflows box

RESOLVED INVALID

Status

()

Core
Layout
P4
trivial
RESOLVED INVALID
16 years ago
14 years ago

People

(Reporter: Grzegorz Adam Hankiewicz, Assigned: Marc Attinasi)

Tracking

({css1, html4, testcase})

Trunk
Future
css1, html4, testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [bae:20020206][CSS1-4.1][HTML4-9.3.4], URL)

Attachments

(2 attachments)

(Reporter)

Description

16 years ago
Given a preformatted text (one contained inside <pre>..</pre>), you can force
the css drawn box to be smaller than the text playing with your brosers' window
width.

The expected behaviour is to have the drawn box at least as wide as the
preformatted text, even if the browser's window is not wide enough to show the
whole preformatted text. Looks like IE 5.5 get's this right.
(Reporter)

Comment 1

16 years ago
Created attachment 67317 [details]
Testcase

Modify your browser's window width to make it smaller and see the box rendered
incorrectly.
(Reporter)

Comment 2

16 years ago
Created attachment 67318 [details]
Screen capture of the bug. Build 2001122108, 0.9.7, Linux, X.
(Reporter)

Updated

16 years ago
Keywords: css1, testcase
Summary: Box width miscalculated for preformatted text → Css box width miscalculated for preformatted text
(Reporter)

Updated

16 years ago
Summary: Css box width miscalculated for preformatted text → Css box width miscalculated for preformatted text, which overflows box
(Reporter)

Comment 3

16 years ago
Build 2002020415 still shows the bug.

Comment 4

16 years ago
confirming the bug, setting to future, P4, already set to trivial
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Linux → All
Priority: -- → P4
Hardware: PC → All
Whiteboard: [bae:20020206]
Target Milestone: --- → Future
Keywords: html4
Whiteboard: [bae:20020206] → [bae:20020206][CSS1-4.1][HTML4-9.3.4]

Comment 5

14 years ago
The width of a block (which is what blockquote is) depends on its parent only,
not on its children. IE is implementing a weasel-hole in the CSS2 box model
which basically says that any horizontal size you want is OK regardless of the
CSS set on the element or any other criteria; that weasel hole is likely to be
removed from the upcoming CSS 2.1.
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.