Cubemap images should be square ("Assertion failure: false (Unexpected GL error.)")

RESOLVED FIXED in Firefox 45

Status

()

Core
Canvas: WebGL
--
critical
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: Jesse Ruderman, Assigned: jgilbert)

Tracking

(Blocks: 1 bug, {assertion, reproducible, testcase})

Trunk
mozilla45
assertion, reproducible, testcase
Points:
---

Firefox Tracking Flags

(firefox45 fixed)

Details

(Whiteboard: gfx-noted)

Attachments

(5 attachments, 1 obsolete attachment)

(Reporter)

Description

2 years ago
Created attachment 8693165 [details]
testcase

Assertion failure: false (Unexpected GL error.), at dom/canvas/WebGLTextureUpload.cpp:1130
(Reporter)

Comment 1

2 years ago
Created attachment 8693166 [details]
stack
I can easily reproduce this on mac.
Keywords: reproducible
Whiteboard: gfx-noted
JavaScript warning: https://bug1228711.bmoattachments.org/attachment.cgi?id=8693165, line 11: Error: WebGL: texImage2D: Unexpected error during upload: 0x0501
texImage2D: dui: 1908/1908/8033
Assertion failure: false (Unexpected GL error.), at /Users/bgirard/mozilla/mozilla-central/tree/dom/canvas/WebGLTextureUpload.cpp:1130
0x0501 = GL_INVALID_VALUE
0x1908 = GL_RGBA
0x8033 = GL_UNSIGNED_SHORT_4_4_4_4
What should webgl be doing with these values?
Flags: needinfo?(jgilbert)
(Assignee)

Comment 6

2 years ago
I am stunned that this isn't tested. It's an INVALID_VALUE because it's a cubemap texImage specification that's non-square.
Assignee: nobody → jgilbert
Flags: needinfo?(jgilbert)
(Assignee)

Comment 7

2 years ago
Created attachment 8695567 [details]
test_cubemap_must_be_square.solo.html
(Assignee)

Comment 8

2 years ago
Created attachment 8695568 [details]
test_cubemap_must_be_square.solo.html
Attachment #8695567 - Attachment is obsolete: true
(Assignee)

Comment 9

2 years ago
Created attachment 8695569 [details] [diff] [review]
0001-Add-a-test.patch
Attachment #8695569 - Flags: review?(bgirard)
(Assignee)

Comment 10

2 years ago
Created attachment 8695570 [details] [diff] [review]
0002-Cubemap-images-must-be-square.patch
Attachment #8695570 - Flags: review?(dglastonbury)
(Assignee)

Comment 11

2 years ago
Comment on attachment 8695570 [details] [diff] [review]
0002-Cubemap-images-must-be-square.patch

Review of attachment 8695570 [details] [diff] [review]:
-----------------------------------------------------------------

:benwa can get this.
Attachment #8695570 - Flags: review?(dglastonbury) → review?(bgirard)

Updated

2 years ago
Attachment #8695569 - Flags: review?(bgirard) → review+
Comment on attachment 8695570 [details] [diff] [review]
0002-Cubemap-images-must-be-square.patch

Review of attachment 8695570 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks!
Attachment #8695570 - Flags: review?(bgirard) → review+
(Assignee)

Updated

2 years ago
Summary: "Assertion failure: false (Unexpected GL error.)" → Cubemap images should be square ("Assertion failure: false (Unexpected GL error.)")

Comment 14

2 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/5cd268005144
Status: NEW → RESOLVED
Last Resolved: 2 years ago
status-firefox45: affected → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla45
You need to log in before you can comment on or make changes to this bug.