Closed Bug 1228951 Opened 8 years ago Closed 8 years ago

only use --good/--bad option parameters

Categories

(Testing :: mozregression, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: parkouss, Assigned: parkouss)

Details

Attachments

(1 file)

So right now we have three distinct options to allow to specify a build range:

> mozregression --good --bad
> mozregression --good-release --bad-release
> mozregression --good-rev --bad-rev

And we have the --launch option that accept every possible values (a date, buildid, release number or revision).

I propose that we remove release/rev arguments to make good/bad options able to accept the same things as the --launch parameter.
So, this patch does the job.

As a bonus, it will fix bug 1225541, because it allows to write things like:

> mozregression -g 2c0df58d9443dec00c684b00b111dfaf96613997

and the bad will be automatically took as the last push changeset in the current day.
Assignee: nobody → j.parkouss
Status: NEW → ASSIGNED
Attachment #8693487 - Flags: review?(wlachance)
Comment on attachment 8693487 [details] [review]
only use --good / --bad parameters

Gave this a brief once-over and it looks good. I very much approve of the general direction of the change, it's nice to reduce the # of possible options where we can.
Attachment #8693487 - Flags: review?(wlachance) → review+
Glad to read that!

Landed in https://github.com/mozilla/mozregression/commit/e6c8c3afde4f388d34c1b516db52f51c01ca9f79
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.