Closed Bug 1228979 Opened 8 years ago Closed 8 years ago

[e10s] Menu popups aren't rendered in Remote XUL

Categories

(Firefox :: General, defect)

x86_64
All
defect
Not set
normal

Tracking

()

RESOLVED WONTFIX
Tracking Status
e10s + ---

People

(Reporter: mark.crutch+bugzilla, Unassigned)

References

Details

When using a Remote XUL page in an e10s tab, menu popups don't appear. Using the inspector in the dev tools suggests they're present, but not visible. They work fine when opened in a non-e10s window.

Steps to Reproduce:

1) Add the "Remote XUL Manager" add-on to Firefox and open its preferences pane.
2) Use the Add button to whitelist https://developer.mozilla.org
3) View one of the XUL menu examples in the XUL tutorial. Examples are:

https://developer.mozilla.org/samples/xultu/examples/ex_menubar_1.xul
https://developer.mozilla.org/samples/xultu/examples/ex_advmenu_1.xul

4) Note that the menu itself is visible, but the popup is not.
5) Optionally open the developer tools to confirm that the relevant elements are highlighted when moving the mouse over the invisible menu popup.



Note on Remote XUL:
Although I appreciate that Remote XUL is well and truly deprecated, we have an intranet application that runs to over 150,000 lines of code based on the technology. We plan to migrate to HTML once Web Components are available, but until then we're stuck with Remote XUL. The examples listed above demonstrate the issue without the need to whitelist an arbitrary domain, but the problem does occur in our real application in exactly the same way.
Blocks: e10s-addons
tracking-e10s: --- → +
Status: UNCONFIRMED → RESOLVED
Closed: 8 years ago
Resolution: --- → WONTFIX
Can I ask for some more information about why this was WONTFIXed? Is there a technical reason for the decision, or just a political one with respect to the official position of Remote XUL?

Incidentally, further testing suggests the problem applies to *all* popups and panels in a Remote XUL application, not just menus.
re-opening since it was rather rudely closed (by me) without explanation.  Will take through next triage to add technical details and thoughts on it.  Sorry, in the beginning of catching up with an area we hadn't been triaging - commenting was sub-par.
Status: RESOLVED → UNCONFIRMED
Resolution: WONTFIX → ---
Remote XUL isn't supported, as you stated in your first comment.
Status: UNCONFIRMED → RESOLVED
Closed: 8 years ago8 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.