Closed Bug 1229351 Opened 4 years ago Closed 4 years ago

Buttons removed from the toolbar will re-appear when the Loop system add-on is activated

Categories

(Hello (Loop) :: Client, defect, P1)

defect

Tracking

(firefox45 verified)

VERIFIED FIXED
mozilla45
Iteration:
45.3 - Dec 14
Tracking Status
firefox45 --- verified

People

(Reporter: standard8, Assigned: standard8)

References

Details

(Keywords: regression, Whiteboard: [go faster])

Attachments

(1 file)

STR:

1) Start an older version of Firefox (e.g. 44) with a fresh profile
2) Right-click on the Hello button, and select "Remove from toolbar"
3) Exit Firefox
4) Start the latest version after bug 1223573 landed

Expected Results

=> Hello button is not on the toolbar

Actual Results

=> Hello button appears on the toolbar

Bug 1229123 has a fix for the customisable UI. I think we just have to add the loop-button to the list it has added, and then we'll be fine.
Tagging for this iteration, as we need to fix this before we move to aurora.
Iteration: --- → 45.3 - Dec 14
Rank: 9
¡Hola Mark!

Is this why Mozilla/5.0 (Windows NT 6.1; WOW64; rv:45.0) Gecko/20100101 Firefox/45.0 ID:20151201030226 CSet: 66a6d7ec9534b9d7847b665142fef0dd87623768 shows this in "Browser Console"?

[CustomizableUI] Custom widget with id loop-button does not return a valid node CustomizableUI.jsm:173
no element found aboutNetError.xhtml:1:1

¡Gracias!
Flags: needinfo?(standard8)
(In reply to alex_mayorga from comment #2)
> ¡Hola Mark!
> 
> Is this why Mozilla/5.0 (Windows NT 6.1; WOW64; rv:45.0) Gecko/20100101
> Firefox/45.0 ID:20151201030226 CSet:
> 66a6d7ec9534b9d7847b665142fef0dd87623768 shows this in "Browser Console"?
> 
> [CustomizableUI] Custom widget with id loop-button does not return a valid
> node CustomizableUI.jsm:173
> no element found aboutNetError.xhtml:1:1
> 
> ¡Gracias!

No, that's bug 1229471, and it is not related.
Flags: needinfo?(standard8)
This is based on the patch in bug 1215694, and fixes the issue in local testing.

Gijs, can you review this and check there's nothing else you think we'll need?
Attachment #8694701 - Flags: review?(gijskruitbosch+bugs)
Comment on attachment 8694701 [details] [diff] [review]
Buttons removed from the toolbar will re-appear when the Loop system add-on is activated.

Review of attachment 8694701 [details] [diff] [review]:
-----------------------------------------------------------------

You'll race with the pocket addition, but yes, I think this is all you need.
Attachment #8694701 - Flags: review?(gijskruitbosch+bugs) → review+
Assignee: nobody → standard8
https://hg.mozilla.org/mozilla-central/rev/a8760b15e213
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla45
Flags: qe-verify+
QA Contact: bogdan.maris
Reproduced under Windows 7 64-bit: after removing the button in Developer Edition 44.0a2 and launching Nightly from 2015-12-01 with the same profile, the Hello button is available in the toolbar.

Verified fixed with latest 45.0a1 (from 2015-12-07), across platforms [1].

[1] Ubuntu 14.04 32-bit, Windows 7 64-bit and Mac OS X 10.11
Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.