Hardware acceleration is broken in Windows 10 with AMD R9 Series GPUs

RESOLVED WORKSFORME

Status

()

Core
Graphics
RESOLVED WORKSFORME
2 years ago
8 months ago

People

(Reporter: djshavit, Assigned: mstange)

Tracking

(Blocks: 1 bug)

49 Branch
x86_64
Windows 10
Points:
---

Firefox Tracking Flags

(platform-rel +)

Details

(Whiteboard: [gfx-noted][2016-GBT-Y][platform-rel-AMD])

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:44.0) Gecko/20100101 Firefox/44.0
Build ID: 20151201004002

Steps to reproduce:

Install Windows 10, get an AMD R9 GPU. (I get this with R9 380)
Enable hardware acceleration.


Actual results:

The CSS filters `filter: hue-rotate(1deg);` and `filter: saturation(10%);` make the part of the page I apply the CSS to disappear instead of render differently.
This issue happens when you have hardware acceleration enabled with an AMD R9 380 GPU on Windows 10. With both Catalyst/Crimson driver releases.
This issue is reported by a few people, the majority of them also have an R9 380 GPU, while some that have another GPU from the R9 Series don't experience this "bug".

Pages become black when specific stuff happen, here's a demonstration video where it happens with RES: https://www.youtube.com/watch?v=nYOHrNZ47sI
* RES is not required for this to happen, it just makes it happen more frequently on reddit.com.
This issue happens when you have hardware acceleration enabled with every AMD R9 Series GPU on Windows 10. With both Catalyst/Crimson driver releases.
This issue is reported by many people and all of them have an AMD R9 Series GPU.


Expected results:

The `hue-rotate` and `saturation` CSS filters should have render the text/images I apply the CSS filter to properly instead of making it disappear.
Pages should not become black randomly.
(Reporter)

Updated

2 years ago
OS: Unspecified → Windows 10
Hardware: Unspecified → x86_64
Component: Untriaged → Graphics
Product: Firefox → Core

Comment 1

2 years ago
Just wanting to chime in here - the blank screen problem happens on my R9 280 as well. I'm not sure about the CSS part.
But here's the interesting thing - it ALSO does this (though less often) on my Intel/Nvidia based laptop - which uses a NVIDIA Quadro NVS 160M. Both are running x64 Windows 10 now but I HAD seen this behavior very rarely on Windows 7.

Resizing the window makes it refresh - sometimes it'll settle for a while, other times not at all and a restart must be done. Turning hardware acceleration off makes the problem go away.
Since the both of you are can replicate I will mark this bug as new and send it up to a dev.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Whiteboard: [gfx-noted]
Whiteboard: [gfx-noted] → [gfx-noted][2016-GBT-Y]

Comment 3

2 years ago
Adding myself into the ring here as a Windows 10 (Pro, 64-bit) user with Firefox 44.0.2 and an AMD Radeon R9 380X (4GB) card using the 15.12 drivers affected by this.

This breaks the icons in "light theme" for the Developer console.  Also, if you're a user of Reddit and have the Reddit Enhancement Suite extension installed and using "night mode" you'll notice that the inline image 'expando' buttons aren't drawn either.

Everything returns to normal if you disable hardware acceleration and restart the browser.

Comment 4

2 years ago
See also:  https://bugzilla.mozilla.org/show_bug.cgi?id=1236563
Bas, we had a nightly or two with the present fix, perhaps you can point us to those versions and people can see if some of the symptoms go away?
Flags: needinfo?(bas)
Blocks: 1236563
(In reply to Milan Sreckovic [:milan] from comment #5)
> Bas, we had a nightly or two with the present fix, perhaps you can point us
> to those versions and people can see if some of the symptoms go away?

Seems highly unlikely to me, but there's no harm in trying: http://ftp.mozilla.org/pub/firefox/nightly/2016/02/2016-02-17-06-26-21-mozilla-central/firefox-47.0a1.en-US.win32.zip
Flags: needinfo?(bas)

Comment 7

2 years ago
Any progress about this bug? A French user gets this issue too: https://forums.mozfr.org/viewtopic.php?f=5&t=129195
Flags: needinfo?(jmuizelaar)
(Reporter)

Comment 8

2 years ago
(In reply to Loic from comment #7)
> Any progress about this bug? A French user gets this issue too:
> https://forums.mozfr.org/viewtopic.php?f=5&t=129195

Not fixed for me.
(Reporter)

Comment 9

2 years ago
Funnily enough I also have the same exact GPU and operating system that the French user has.
Flags: needinfo?(howareyou322)
djshavit, what driver version do you see this on?
Flags: needinfo?(jmuizelaar) → needinfo?(djshavit)
mstange, can you reproduce this?
Flags: needinfo?(mstange)
(Reporter)

Updated

2 years ago
Version: 44 Branch → 47 Branch
(Reporter)

Comment 12

2 years ago
Jeff Muizelaar, AMD Radeon Crimson 16.4.2 drivers and AMD Radeon Crimson 16.3.2 (WHQL)
(Reporter)

Comment 13

2 years ago
This bug still exists in Aurora (Firefox 47)
(Reporter)

Updated

2 years ago
Flags: needinfo?(djshavit)
(Assignee)

Comment 14

2 years ago
I could not reproduce this using my R9 390 using the AMD Radeon Crimson 16.4.2 driver. I don't have an R9 380.
I only tested the devtools, all icons showed up normally in the light theme. I did not test with RES.
Flags: needinfo?(mstange)
(Reporter)

Updated

2 years ago
Version: 47 Branch → 48 Branch
(Reporter)

Comment 15

2 years ago
You should also try to see if SVG filters make the element disappear.

The issue is known for R9 285, R9 380 and R9 380x (and possibly Fury series cards) - no other cards are affected.

Comment 16

2 years ago
This is still an issue for me using Firefox 46, Radeon R9 380 with 16.3.2 drivers.

Updated

2 years ago
Flags: needinfo?(howareyou322)
(Reporter)

Comment 17

2 years ago
I also found that the SSL notification disappears with hardware acceleration. It doesn't happen when H.W.Acceleration is disabled.
Example video footage: https://cdn.shigetora.pw/v/xhbqhcq.mp4

I have also noticed that the issue of specific pages making Firefox go totally black returned.
Example page: https://www.maxkeyboard.com/index.php?dispatch=keyboard_designer.get_order_layout&order_id=19438&product=867089970
Being in this page for a while and interacting with the page (moving mouse etc) will cause the browser to go black.

Firefox 48.0a2 (Developer Edition) and latest AMD drivers (16.5.3).
(Reporter)

Comment 18

2 years ago
After some testing, all of those issues go away if I enable `gfx.direct2d.disabled` through about:config!

The sad part, is that fonts look absolutely disgusting and everything is unreadable if I use this workaround.

Comment 19

2 years ago
I ran a few benchmarks like FishGL and Fishbowl and got lousy frame rates especially with a lot of fishes.  I narrowed down the problem with e10s.  I disabled e10s and I can run at 60fps with the maximum number of fishes.


Application Basics
------------------

Name: Firefox
Version: 49.0a1
Build ID: 20160527073137
Update Channel: default
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:49.0) Gecko/20100101 Firefox/49.0
OS: Windows_NT 10.0
Multiprocess Windows: 1/1 (Enabled by user)
Safe Mode: false


Graphics
--------

Features
Compositing: Direct3D 11
Asynchronous Pan/Zoom: wheel input enabled; touch input enabled
WebGL Renderer: Google Inc. -- ANGLE (AMD Radeon (TM) R9 390 Series Direct3D11 vs_5_0 ps_5_0)
Hardware H264 Decoding: Yes; Using D3D11 API
Direct2D: true
DirectWrite: true (10.0.10586.0)
GPU #1
Active: Yes
Description: AMD Radeon (TM) R9 390 Series
Vendor ID: 0x1002
Device ID: 0x67b1
Driver Version: 16.200.1013.0
Driver Date: 5-20-2016
Drivers: aticfx64 aticfx64 aticfx64 amdxc64 aticfx32 aticfx32 aticfx32 amdxc32 atiumd64 atidxx64 atidxx64 atiumdag atidxx32 atidxx32 atiumdva atiumd6a atitmm64
Subsys ID: 00000000
RAM: 4095

Diagnostics
ClearType Parameters: D [ Gamma: 2200 Pixel Structure: R ClearType Level: 100 Enhanced Contrast: 50 ] D [ Gamma: 2200 Pixel Structure: R ClearType Level: 100 Enhanced Contrast: 50 ]
AzureCanvasAccelerated: 0
AzureCanvasBackend: direct2d 1.1
AzureContentBackend: direct2d 1.1
AzureFallbackCanvasBackend: cairo
ClearType Parameters: D [ Gamma: 2200 Pixel Structure: R ClearType Level: 100 Enhanced Contrast: 50 ] D [ Gamma: 2200 Pixel Structure: R ClearType Level: 100 Enhanced Contrast: 50 ]

Comment 20

2 years ago
Discovered my problem.  Evidently the Crimson drivers downclock more aggressively than previous drivers.  When running the Fish benchmarks my GPU clock was running much lower then the default.  Same thing with my GPU memory clock.  I now use a 3rd party program called ClockBlocker to keep my GPU/Memory clocks at their defaults.  Don't know if this just affects R9 3xx and above cards or not.
With this being a recent driver, Jeff, can you pass it to AMD?
Flags: needinfo?(jmuizelaar)
(Reporter)

Comment 22

2 years ago
I did report it a few times since I filed this bug, nothing changed.
(Reporter)

Updated

2 years ago
Version: 48 Branch → 49 Branch
(Reporter)

Comment 23

2 years ago
Black screens are also a thing again. Firefox 49 (Developer Edition) and newest AMD Crimson drivers (R9 380)

Comment 24

2 years ago
(In reply to djshavit from comment #22)
> I did report it a few times since I filed this bug, nothing changed

We tried unsuccessfully to repro the issue to start an investigation on recent drivers. The downclock info is useful, but are you saying that if you up the clocks the problem goes away?
Flags: needinfo?(djshavit)
Flags: needinfo?(jmuizelaar)

Comment 25

2 years ago
Can you please retest with the 16.6.2 drivers at http://support.amd.com/en-us/download/desktop?os=Windows+10+-+32 or equivalent download links?
(Reporter)

Comment 26

a year ago
Update: Black screens are gone again after updating to the most recent AMD driver.

Again, CSS filters disappear! Footage video: https://www.youtube.com/watch?v=ek7Fxh9zZw8

Newest AMD Crimson drivers, newest Firefox Developer Edition build, Sapphire R9 380 Nitro GPU, Windows 10 64-bit.
Flags: needinfo?(djshavit)
(Reporter)

Comment 27

a year ago
AMD Crimson was updated to 16.8.2, problem still persists.
Duplicate of this bug: 1298137
(Assignee)

Comment 29

a year ago
We found a R9 285 in the Mozilla Toronto office and can reproduce this. We're using driver version 15.300.1025.1001.
I'll try to find a workaround.
Assignee: nobody → mstange
Status: NEW → ASSIGNED
(Assignee)

Comment 30

a year ago
Created attachment 8786438 [details]
testcase
Paul, can you reproduce this on a R9 285 with the attached testcase using driver 15.300.1025.1001? Without a workaround we're probably going to have block Direct2D on these chips.
Flags: needinfo?(paul.blinzer)

Comment 32

a year ago
Jeff, Markus, thank you for providing the simplified test case. I can repro the issue reliably on one of my boards here and will follow up internally.
Flags: needinfo?(paul.blinzer)

Comment 33

a year ago
(In reply to Markus Stange [:mstange] from comment #30)
> Created attachment 8786438 [details]
> testcase
Thank you for providing the repro test case. Bug has been root caused, fixed and will be available in an upcoming driver release.
(Assignee)

Comment 34

a year ago
Thank you! Do you have a suggestion for a workaround?

Comment 35

a year ago
(In reply to Markus Stange [:mstange] from comment #34)
> Thank you! Do you have a suggestion for a workaround?

Nothing obvious to recommend right now.

Comment 36

a year ago
As described in bug 1298137, I also have this problem.
My configuration:
Firefox 48.0.2 (64-bit)
OS: Windows 10 (64-bit)
Graphics Hardware: AMD Radeon R9 380 (Sapphire Nitro 4G)
Graphics Driver: AMD Crimson 16.8.2

Also, SVG filters don't work either. Naturally, when I disable hardware acceleration they work fine.
For reference I use this page: https://developer.mozilla.org/en-US/docs/Web/CSS/filter
On my machine, only CSS filters blur() and drop-shadow() produce a result when I enable hardware acceleration.

Comment 37

a year ago
I use Windows 10 (x64) and the latest AMD driver "Non-WHQL-Win10-64Bit-Radeon-Software-Crimson-16.9.1-Sep7". Now Firefox 48.0.2 seems to be working with hardware acceleration enabled. All icons in the developer toolbar are displayed.
(Reporter)

Comment 38

a year ago
Can confirm, everything works fine!
Status: ASSIGNED → RESOLVED
Last Resolved: a year ago
Resolution: --- → INVALID

Updated

a year ago
Resolution: INVALID → WORKSFORME
This will still be broken for people without up to date drivers so we need to either workaround or blacklist.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
See Also: → bug 1304360, bug 1276408
platform-rel: --- → ?
Whiteboard: [gfx-noted][2016-GBT-Y] → [gfx-noted][2016-GBT-Y][platform-rel-AMD]
(In reply to Jeff Muizelaar [:jrmuizel] from comment #39)
> This will still be broken for people without up to date drivers so we need
> to either workaround or blacklist.

Did we decide what to do?
platform-rel: ? → +
Flags: needinfo?(mstange)
Flags: needinfo?(jmuizelaar)
(Assignee)

Comment 41

a year ago
It would be nice to find a workaround but I haven't yet had the time to look into it.
Flags: needinfo?(mstange)

Comment 42

a year ago
I seem to have the same issue (I got here from bug #1236563). However, I'm using slightly different hardware. I'm also running Windows 10, but I don't have a dedicated GPU. Instead I'm using AMD Radeon R5 Graphics, built into my AMD A10-9600P CPU.

According to about:support,

Graphics
Features
Compositing	Direct3D 11
Asynchronous Pan/Zoom	none
WebGL Renderer	Google Inc. -- ANGLE (AMD Radeon(TM) R5 Graphics Direct3D11 vs_5_0 ps_5_0)
Hardware H264 Decoding	No; Hardware video decoding disabled or blacklisted
Direct2D	true
DirectWrite	true (10.0.14393.321)
GPU #1
Active	Yes
Description	AMD Radeon(TM) R5 Graphics
Vendor ID	0x1002
Device ID	0x9874
Driver Version	16.101.1311.1001
Driver Date	3-8-2016
Drivers	aticfx64 aticfx64 aticfx64 amdxc64 aticfx32 aticfx32 aticfx32 amdxc32 atiumd64 atidxx64 atidxx64 atiumdag atidxx32 atidxx32 atiumdva atiumd6a atitmm64
Subsys ID	00000000
RAM	384
Diagnostics
AzureCanvasAccelerated	0
AzureCanvasBackend	direct2d 1.1
AzureContentBackend	direct2d 1.1
AzureFallbackCanvasBackend	cairo
Decision Log
D3D9_COMPOSITING	
disabled by default: Disabled by default

Comment 43

11 months ago
(In reply to Inkbug from comment #42)
> I seem to have the same issue (I got here from bug #1236563). However, I'm
> using slightly different hardware. I'm also running Windows 10, but I don't
> have a dedicated GPU. Instead I'm using AMD Radeon R5 Graphics, built into
> my AMD A10-9600P CPU.
> 
> According to about:support,
> 
> Graphics
> Features
> Compositing	Direct3D 11
> Asynchronous Pan/Zoom	none
> WebGL Renderer	Google Inc. -- ANGLE (AMD Radeon(TM) R5 Graphics Direct3D11
> vs_5_0 ps_5_0)
> Hardware H264 Decoding	No; Hardware video decoding disabled or blacklisted
> Direct2D	true
> DirectWrite	true (10.0.14393.321)
> GPU #1
> Active	Yes
> Description	AMD Radeon(TM) R5 Graphics
> Vendor ID	0x1002
> Device ID	0x9874
> Driver Version	16.101.1311.1001
> Driver Date	3-8-2016
> Drivers	aticfx64 aticfx64 aticfx64 amdxc64 aticfx32 aticfx32 aticfx32
> amdxc32 atiumd64 atidxx64 atidxx64 atiumdag atidxx32 atidxx32 atiumdva
> atiumd6a atitmm64
> Subsys ID	00000000
> RAM	384
> Diagnostics
> AzureCanvasAccelerated	0
> AzureCanvasBackend	direct2d 1.1
> AzureContentBackend	direct2d 1.1
> AzureFallbackCanvasBackend	cairo
> Decision Log
> D3D9_COMPOSITING	
> disabled by default: Disabled by default

The driver you are using for the product is quite old and should be updated. That should address the issue. Could you please install the most recent driver (which contains the fix) and report back? 

http://support.amd.com/en-us/download/apu?os=Windows+10+-+64
Flags: needinfo?(ynovetsky)

Comment 44

11 months ago
I have updated my driver, and everything seems to be fixed. The testcase is now showing a green square.
I'm now using the Radeon driver version 16.12.1.
Flags: needinfo?(ynovetsky)

Comment 45

11 months ago
Thanks for confirming. I think this bug should be closed again and the workaround task for similar issues tracked in a new item, if a blacklist entry for this issue with pre-16.9.x AMD Crimson drivers is not considered. 
Based on the bug cross-references workarounds are also necessary for older drivers from other vendors so a vendor-neutral refactoring of the code may be an option.
In general, nudging the end users to newer stable driver releases (e.g. to Windows Update released drivers) would be the preferred solution here.

Comment 46

11 months ago
Fine with me. However, please note that the driver update I needed to do could not be found in Windows Update, but rather I had to specifically go to the AMD Radeon Settings to find the update.

Comment 47

8 months ago
I posted ~ a year ago in this thread putting my hat in the ring of affected users.  I'm now running Firefox 52.0.2 (32 bit) on Windows 10.  I still have the same AMD Radeon R9 380 card, but I just updated my drivers to 17.4.1 and when I look at the Developer mode using the Light theme, I can see all the icons now.  And my issue I reported about reddit and the Reddit Enhancement Suite add-on also seems to be resolved.

Comment 48

8 months ago
(This is with hardware acceleration enabled, by the way.)
(Assignee)

Comment 49

8 months ago
Thanks for reporting back!

It doesn't look like we're going to search for a workaround at this point, so I'm going to close this bug.
Status: REOPENED → RESOLVED
Last Resolved: a year ago8 months ago
Flags: needinfo?(jmuizelaar)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.