Failing to use the right group symbol on Treeherder

RESOLVED DUPLICATE of bug 1215587

Status

RESOLVED DUPLICATE of bug 1215587
3 years ago
3 years ago

People

(Reporter: armenzg, Unassigned)

Tracking

Details

(Reporter)

Description

3 years ago
You will see a group of jobs [1] under "W[Tier-2]" grouping.
However, I believe it should be "tc-W[Tier-2]" according to the task defition [2]
>    "treeherder": {
>      "groupSymbol": "tc-W",

You can see the yml job defines it right afaict [3]

On the other hand, this task falls under the right grouping [4]

[1] https://treeherder.mozilla.org/#/jobs?repo=try&revision=c40ae120eaf2&filter-searchStr=web-platform-tests
[2] https://tools.taskcluster.net/task-inspector/#YFXdsPcTSZum-IRa-QydQA/
[3] https://hg.mozilla.org/try/file/367c07530ada/testing/taskcluster/tasks/tests/fx_linux64_web-platform-tests.yml#l26
[4] https://queue.taskcluster.net/v1/task/TY_TjjueT5e_dxCO2u2PvA
Has the group symbol changed? I believe treeherder caches the symbol. :(
Component: General → Treeherder
Product: Taskcluster → Tree Management
Version: unspecified → ---
(I had the same issue)
(Reporter)

Comment 3

3 years ago
camd: I'm having trouble with the representation of a group symbol.
It might have been cached since I've been changing it on try.
Flags: needinfo?(cdawson)
(Reporter)

Comment 4

3 years ago
I can see that further chunks would fall into the right category (1 to 4 fall into the old group)
https://treeherder.mozilla.org/#/jobs?repo=try&revision=c3b6f46fa757&filter-searchStr=web-platform&group_state=expanded
Armen: yeah, this is another unfortunate side-effect of bug 1215587.  I think this is something we should discuss at Mozlando.  
I can fix the DB directly for these particular jobs, however.  I think that's what I need to do for now till we get a real fix in.
Flags: needinfo?(cdawson)
(Reporter)

Updated

3 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1215587
You need to log in before you can comment on or make changes to this bug.