Closed Bug 1229424 Opened 6 years ago Closed 6 years ago

"ASSERTION: CalcDifference() returned bigger hint than MaxDifference()"

Categories

(Core :: CSS Parsing and Computation, defect)

defect
Not set
normal

Tracking

()

RESOLVED FIXED
Tracking Status
firefox45 --- affected

People

(Reporter: jruderman, Assigned: xidorn)

References

(Blocks 1 open bug)

Details

(Keywords: assertion, regression, testcase)

Attachments

(2 files)

Attached file testcase
###!!! ASSERTION: CalcDifference() returned bigger hint than MaxDifference(): 'NS_IsHintSubset(difference, maxDifference)', file layout/style/nsStyleContext.cpp, line 923

This is a regression from within the last few days. I suspect bug 1040668, since its patch affects text-related CSS properties and special-cases 'zh'.
Attached file stack
This is because I forgot to add UpdateOverflow to MaxDifference() in bug 1040668 patch 1. This specific assertion will be fixed in bug 1225018. There is one similiar assertion for text-emphasis-style which will be fixed in bug 1229278.
No longer blocks: 1040668
Depends on: 1225018
(Removed bug 1040668 from "Blocks" because of cyclic dependency)
The changeset that failed to update nsStyleText::MaxDifference was https://hg.mozilla.org/mozilla-central/rev/d57862a8ffca -- but as we discussed elsewhere yesterday, I think it should be using UpdateSubtreeOverflow rather than UpdateOverflow.
Assignee: nobody → quanxunzhen
This should have been fixed by bug 1225018.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.