Wrong z-order for flash objects during APZ scrolling

RESOLVED DUPLICATE of bug 1152049

Status

()

defect
RESOLVED DUPLICATE of bug 1152049
4 years ago
3 years ago

People

(Reporter: vladan, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

()

Attachments

(1 attachment)

Reporter

Description

4 years ago
Scrolling the Flash ads in the sidebar on http://syria.liveuamap.com causes the ads to have topmost z-order, passing over the top of the page

Example ad code:

<object id="flashObjSekindoVPlayer24610" data="http://live.sekindo.com/content/video/vplayer/vPlayer_v1.0.9.swf" type="application/x-shockwave-flash" width="300" height="250"> <param name="allowfullscreen" value="true"><param name="movie" value="http://live.sekindo.com/content/video/vplayer/vPlayer_v1.0.9.swf"><param name="allowscriptaccess" value="always"><param name="quality" value="high"><param name="bgcolor" value="#000000"><param name="wmode" value="window"></object>
Do you know if this is the same underlying issue as bug 1152049?
Flags: needinfo?(jmathies)
OS: Unspecified → Windows 7
Doesn't sound like it. I can't reproduce though on this page. The ads and videos are clipped correctly by the sidebar afaict.

vladan, do you have specific str here?
Flags: needinfo?(jmathies) → needinfo?(vladan.bugzilla)
(Also a screenshot would be helpful)
Reporter

Comment 4

4 years ago
Posted image Screenshot
STR:
1. Load http://syria.liveuamap.com 
2. Set the "src" attribute of one of the ad iframes in the sidebar to "http://people.mozilla.org/~vdjeric/bug1229451.html"
For example: document.getElementById("aswift_3").src = URL;
3. Scroll the sidebar down until the newly added flash object covers the top of the page (see screenshot)
Flags: needinfo?(vladan.bugzilla)
Ok, I was able to reproduce with apz enabled. dom scroll works fine. It looks like the plugin window doesn't get updated clipping as the content scrolls. It's not the same problem as bug 1152049 (that's chrome clipping vs. content) but it might get fixed by the same patch. Marking dependent.
Depends on: 1152049
Bug 1152049 just landed on m-c, can you please check on the next nightly to see if this still happens? Thanks!
Flags: needinfo?(vladan.bugzilla)
Reporter

Comment 7

3 years ago
Yes, the Z-order issue is fixed.
The flash object blinks when it's scrolled but I think that's a different known bug
Flags: needinfo?(vladan.bugzilla)
Awesome, thanks for checking!
Status: NEW → RESOLVED
Last Resolved: 3 years ago
No longer depends on: 1152049
Resolution: --- → DUPLICATE
Duplicate of bug: 1152049
You need to log in before you can comment on or make changes to this bug.