Closed Bug 1229473 Opened 6 years ago Closed 5 years ago

Hang in nsCSSBorderRenderer::DrawBorderSides

Categories

(Core :: Layout: Block and Inline, defect)

defect
Not set
critical

Tracking

()

RESOLVED FIXED
mozilla50
Tracking Status
firefox45 --- affected
firefox50 --- fixed

People

(Reporter: jruderman, Unassigned)

References

(Blocks 1 open bug)

Details

(Keywords: hang, testcase)

Attachments

(3 files)

No description provided.
Attached file hang sample
Can you tell whether this is a regression?
Flags: needinfo?(jruderman)
Component: Layout → Layout: View Rendering
Not easily.
Flags: needinfo?(jruderman)
OK.  I just spot-checked and Fx41 has the same problem, so it's not a recent regression, at least.
Blocks: 1236224
Component: Layout: View Rendering → Layout: Block and Inline
OS: Unspecified → All
Hardware: Unspecified → All
Attached patch wallpaperSplinter Review
I tend to think we should wallpaper this bug for now.
This patch renders the border in black (fast) instead of hanging,
for border sizes > 10000px.   AFAIK, we only execute this path for
-moz-border-*-colors which is probably rare on the web.

Looks green:
https://treeherder.mozilla.org/#/jobs?repo=try&revision=6e25c6ccd497
Attachment #8763509 - Flags: review?(tnikkel)
Attachment #8763509 - Flags: review?(tnikkel) → review+
Pushed by mpalmgren@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/9a6b2786a581
Don't use composite colors for border sizes > 10000px because it's too slow.  r=tn
https://hg.mozilla.org/mozilla-central/rev/9a6b2786a581
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla50
You need to log in before you can comment on or make changes to this bug.